Support » Plugin: AMP » Post-Processor cache keeping getting disabled

  • The post-processor cache was disabled due to detecting randomly generated content found on this web page.

    Randomly generated content was detected on this web page. To avoid filling up the cache with unusable content, the AMP plugin’s post-processor cache was automatically disabled.

    This keeps happening, sometimes almost daily and every time it reports a different webpage. How do I stop this from happening? Site is https://www.reviewcenter.in/

    • This topic was modified 2 months, 4 weeks ago by  luckyankit.
Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Pascal Birchler

    (@swissspidy)

    > How do I stop this from happening?

    Stop having dynamically changing content 😉

    If you check the source code of your site, there’s some HTML like this at the bottom:

    <!--
            Theme: Newspaper Mobile Theme by tagDiv 2019
            Version: 9.7.3 (rara)
            Deploy mode: deploy
            Speed booster: v4.9.3
    
            uid: 5d304bcdbb31e
        -->

    Where the uid changes on every page load. That’s probably the randomly generated content that the AMP plugin encounters. You should contact your theme’s developer to find out how you can disable that output.

    I also see that you are using the Cookies for Comments plugin which adds some invisible image with a randomly changing URL, e.g. https://www.reviewcenter.in/wp-content/plugins/cookies-for-comments/css.php?k=59c7b7adcdb0956b082ee18721bda416&o=i&t=1720021093.

    You should probably just disable this plugin on AMP endpoints or even completely turn it off. You can also try contacting that plugin’s developer to see what they can do about it.

    I am using the same plugin on another site too, and it doesn’t happen there. I’ll still keep an eye on it as I installed the plugin yesterday only. But yeah that code being generated by theme could be the issue creator. Thanks a lot for the quick reply.

    Although I wish if there was an option provided by AMP plugin to remove HTML comments in the rendered page as the cache plugins fail to do so.

    Plugin Author Pascal Birchler

    (@swissspidy)

    @luckyankit That’s an interesting suggestion! I’ll make sure to write it down so we can consider it for a future version.

    Thank you

    Plugin Author Weston Ruter

    (@westonruter)

    I’m having the same issue, I can’t find anything dynamic in my pages that would cause the cache to be disabled. Yet it will just randomly report a different page each time including my homepage that is causing the problem so it seems to be something on every page. If anyone can check it out and find the reason that would be great https://www.ryansmithphotography.com.

    Plugin Author Weston Ruter

    (@westonruter)

    @rsmith4321 It’s not really a big deal if the cache is disabled, as long as you also have a full page WordPress caching plugin as well. In fact, we may get rid of the post-processor cache altogether because it is proving brittle.

    Actually that is what I was thinking since I had full page caching I didn’t know if it would make a difference. That is good to know I’ll just not worry about it then.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.