Support » Requests and Feedback » Post Preview still not working in 2.5.1

  • My post preview when writing/editing a post hasn’t worked since upgrading to 2.5. I saw on here that others have been experiencing the same issue and hoped that 2.5.1 would fix it, but it didn’t.

    I’d really appreciate that getting fixed ASAP as I don’t like having to publish before seeing the layout and having to make formatting corrections on a live post.

Viewing 9 replies - 1 through 9 (of 9 total)
  • May I ask what browser you are using while blogging. and if you have a pop up blocker active?

    Oh, the preview button is there, right at the top on the right. You don’t even have to save to use it. And your preview window will update with the reload button on your browser. Course I’m using Camino browser now, since yesterday, on my Mac. So much smoother. doesn’t presume to alter your code like Firefox sometimes does.
    It does load Preview in new window or tab, no popup. but I did use the no_flash_popup plugin to get my Media add to work.

    There is a sweet hack for the write/edit panel by a knitter of all things. Gets some of that stuff from the bottom back up to the right.
    Good luck, Penny P


    Penny, sorry, the preview button says ‘View this Post” and will take you to a new page or tab. when you make changes to the post, you can reload the preview for the new edits.

    Let us know if this works for you.


    Thanks for the response. My main browser is Firefox, but I have tried writing/editing my posts in all the browsers I have: Opera, SeaMonkey, Safari and IE6 (I have all these so I can make sure my websites are compatible), but the preview doesn’t work in any of them. I do have a popup blocker, but it’s not blocking my previews.

    When I click on “Preview this post” the new window opens with all my blog header and sidebar and everything, but I get a “Sorry, no posts matched your criteria.” instead of the post. (I don’t get a 404 – Not Found.)

    The link of the preview page, if it matters, reads something like:

    I wonder if it has to do with my permalink structure which is
    post-title/post-id and whether the /?p=200&preview=true isn’t matching things up correctly. I didn’t have a problem with the previews before upgrading to 2.5, so I’m not sure about this.


    Thanks for the link to the hack. I’ll definitely think about it, though I’m hoping for a fix that won’t require having to install another add-on because I already have so many plugins I have to keep updated. I may end up trying it out though if I can’t get this fixed soon.


    Thanks again to both of you for your responses.
    Penny P

    Penny, this works for most (at least for me), so it isn’t a WP bug or something. I can only suggest troubleshooting. Try changing permalinks to default, change theme to default, deactivate plugins, etc. One by one of course, otherwise you still won’t know what caused the problem.

    Perhaps this guy has some suggestions you can try.


    Thanks a million for your help. It turns out it was the “1 Blog Cacher” Plugin that was causing the problem. Lucky for me it’s listed first because of the 1 in the title and was the first and only plugin I had to deactivate to find the culprit!

    Thanks again. It is so nice to have it working again.
    Penny P

    Hey, where did the “resolved” button go?

    Oh, I guess “requests and feedback” wouldn’t have one. Sorry.

    Not resolved for me though. Problem has nothing to do with finding the preview button or screen. Ever since my upgrade to 2.5.1, the preview pane still hits URLs of the format: “”. But that URL format now always returns 404s for any unpublished files.

    This looks to be a continuation of the unresolved problem discussed here:

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Post Preview still not working in 2.5.1’ is closed to new replies.