Support » Fixing WordPress » Post Preview Not Working After Upgrading to 5.0.3

  • Resolved suishouyuki2

    (@suishouyuki2)


    After browsing forums and trying various tips, I’m finally resorting to making an account here and posting in hopes my problem will get fixed!

    Upon upgrade, the new block editor continuously fails to save. It also does not let me view post previews. (It just sits there on the WordPress logo and does nothing.) Switching to the Classic Editor Plugin allows me to save and post, but I still can’t view previews. It throws a 404 error and says the page doesn’t exist. (Before I updated my theme, it said I didn’t have permission to view post drafts, which is insane since I’m the administrator and only site user!)

    I have run the Health Check Plugin, and it shows no issues regarding REST API. In troubleshoot mode, even with all plugins disabled and using the TwentyNineteen theme, the issue persists. Disabling all but the Classic Editor makes no difference.

    My htaccess file has nothing wrong with it. The only thing I’d added was Options -Indexes after the WordPress code to prevent file directories from showing.

    I have cleared my browser’s cache, and it didn’t help.
    I have repeatedly tried resaving permalinks, and it doesn’t help.
    All plugins and themes are up to date.

    The only other thing I can think of to do at this point is somehow revert to the UpdraftPlus backup I made just before I upgraded.

    Does anyone have any other ideas?? I was all set to be excited about the block editor because I thought it would make the process faster. Instead, it completely screwed up the process and I’ve wasted several hours on this now 🙁

    At least I can still post, thanks to the Classic Editor Plugin, but it would be great to be able to preview posts again.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hello suishouyuki2,

    Good thing is you got a backup.
    I would try the relocate thingy https://codex.wordpress.org/Changing_The_Site_URL#Relocate_method

    Edit:
    Or check the URL Settings first

    • The “Site Address (URL)” setting is the address you want people to type in their browser to reach your WordPress blog.
    • The “WordPress Address (URL)” setting is the address where your WordPress core files reside.
    • This reply was modified 5 months, 3 weeks ago by  Maurice.

    Hi @mohaftig,

    Thanks for your input!

    The URL settings are the same. The only thing is that they both point to http instead of https. Would it mess anything up if I changed them to https?

    I’m not a programmer and so I really don’t want to dig into coding unless I absolutely have to (and unless I’m armed with impeccable tutorials). How would the relocate thing help?

    I have a VPS server with DreamHost and don’t know anything about moving servers.

    Thanks,
    Yuki

    Sometimes WordPress is installed in a different folder than your domain is pointing at. For several reasons.

    /server/domain
    /server/more_other_things
    /server/other_things
    /server/wordpress

    The relocate finds out where WordPress is and updates the setting. But I’m only guessing that there is somewhere something wrong with some redirection.

    Changing the http to https could be already it.

    I see! I’m pretty sure I installed on my main directory.

    ABSPATH is /home/vpsyuki/yuki-online.com/

    (where vpsyuki is my server)

    WP_HOME and WP_SITEURL both say “Undefined” in Health Check under “WordPress Constants” but it also says home URL under “WordPress” is http://yuki-online.com, while site URL is https://yuki-online.com.

    In my general settings in WordPress, both are listed as http://yuki-online.com.

    I just opened up WebFTP and confirmed all the WordPress files are within that domain. So it’s not server/wordpress, it’s server/domain/wp-content etc.

    Could it just be a https issue? It’s never been a problem until I upgraded to 5.0.3. If I changed the home URL to https, would that mess up anything?

    No. Just double check for misspelling.

    And if something goes wrong, it’s only copy + paste to revert:
    https://codex.wordpress.org/Changing_The_Site_URL#Edit_functions.php

    Thank the Lord. Okay. I just switched both links to https and logged back in, and now I’m able to see draft previews again!

    Then I turned on Troubleshooting mode and tried using the new block editor, and was able to preview. Drafts are now automatically saving like normal now too, even with all plugins activated.

    Thank you for your help!

    You’re welcome.

    Please also change the images in your widgets to https.

    src=”http://…”

    to

    src=”https://…”

    That should remove the “not secure warning”

    • This reply was modified 5 months, 3 weeks ago by  Maurice.
    • This reply was modified 5 months, 3 weeks ago by  Maurice.
Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.