Support » How-To and Troubleshooting » Post Preview not Working

Post Preview not Working

Viewing 15 replies - 16 through 30 (of 31 total)
  • I have the same problem. I click on Preview and I go to theme page and the 404 error. I’m now at 2.8.4. Gears is not running

    The Other error is Sorry, no posts matched your criteria.

    I’m having the same problem in 2.8.4 with the error Sorry, no posts matched your criteria. I think it has to do with firefox, as I can preview just fine in IE8.

    Anyone have any suggestions?

    I’m having the same problem in 2.8.4. WordPress address and blog address are the same. Hmmm …

    Same problem. There must be a solution other than having to mess with .htaccess. Yargh!

    I’ve had this “no posts matched…” preview problem since 2.7. Today’s upgraded puts me at 2.8.4 and still no fix. I have yet to this resolved. I have to say WordPress is very disappointing….

    Anyone has a solution to this? I would love to be able to preview posts again. It went haywire after the upgrade. Also no offense, but these are these least helpfull forums on the net. I have no problem responding to people in forums, but here it’s just hard to get a response from anyone about any topic.

    You would think an open community would be more open.. – Rant mode off.

    I fixed mine by changing my Permalinks structure, saving, and then putting it back and saving again. I’m assuming it edited the .htaccess file in the background and has made it readable again. Didn’t have to edited it myself, which is a huge relief.

    Are there any other options for fixing this? Changing permalinks did not help. I onlyhave this problem with IE. I can preview if I use Firefox or Chrome, just not IE.

    I faced this problem in WordPress 2.8.6 and solved it by following these steps:

    1. Create a blank .htaccess file in Blog folder.
    2. Go to Settings-> Permalinks
    3. Select a common setting.
    4. Save Changes.
    5. Copy all code from Permallinks (code showing at the bottom of Permallinks screen) and past in .htaccess file.
    6. save you .htaccess file.
    7. Change this .htaccess file with 777 full write permission. (This step is very important)
    8. Repeat once again Step 2, step 3, step 4. (You may not need to follow step 8 (Optional))
    9. Post a new or Edit your old post
    10. Confirm your Preview Changes by clicking it.

    If you are still facing this problem, please copy code for .htaccess file from Permallinks and paste it to .htaccess file in WordPress core file folder. Give full write permission (777). Try preview (Step 9 and Step 10)
    I hope it will work fine.

    If everything is allright, please change .htaccess file permission 705 or 604 for your web security.

    Good luck!


    Please enter “ftp user name” and “path” into index.php in blog folder.

    /** Loads the WordPress Environment and Template */

    Another possibility (I’m using 2.8.6): try a different browser.

    Having never had one problem with WordPress until today, I suddenly found my preview post button not working. After trying everything from file permissions to resetting my Permalinks to disabling plugins to changing my theme, I thought back to the only major thing I had changed in the last 24 hours. My browser.

    For whatever reasons, Google Chrome for Mac is giving me the “no matching entries found” error. Logged in with Firefox, and preview is working just fine. Go figure.

    I fixed the problem on my blog. In the settings general, be sure the WordPress address (URL) and the Blog address (URL) match.

    Thank you agroguru! That worked! I’ve been dealing with that frustration for a couple of upgrades and almost stopped blogging. I’d have had no idea it was such an easy, elegant fix.

    P.S. And it fixed some other little annoying problems as well!
    Wow. I might actually start to enjoy blogging again…maybe you should put your name as “wordpressguru” 🙂

Viewing 15 replies - 16 through 30 (of 31 total)
  • The topic ‘Post Preview not Working’ is closed to new replies.