Support » Plugin: Popup Maker - Popup for opt-ins, lead gen, & more » Post Popups not working anymore ?

  • Resolved thomasdenoncin

    (@thomasdenoncin)


    Hello.
    We were planning on using Popup maker on a project, more specifically the Post Popups as decribed here :
    http://docs.wppopupmaker.com/article/53-create-read-more-popups-for-posts

    But even the code in the page pasted on our website without any modification doesn’t work. In every browser we have tried a javascript error prompt with this message :
    Uncaught TypeError: Cannot read property ‘mobile_disabled’ of undefined

    Any idea on how to fix this ?

    Thanks in advance,
    Thomas

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Daniel Iser

    (@danieliser)

    @thomasdenoncin – Do you have a link we can look at? I think I may know the issue but need to work out how to solve it locally first. It will be patched quickly though.

    Thread Starter thomasdenoncin

    (@thomasdenoncin)

    @danieliser – Unfortunally we only have it locally for now. But as I said we pasted the code shown in the demo here :
    http://docs.wppopupmaker.com/article/53-create-read-more-popups-for-posts

    Please let me know when the issue is fixed.

    Many thanks,
    Thomas

    @thomasdenoncin

    Like Daniel mentioned, we need to see it live on your site – if you could provide an URL when it’s available we can investigate the issue further.

    Thanks!

    Closing this ticket due to inactivity. If you’re still having an issue, create a new thread, link this one, and we will continue troubleshooting.

    Please take a moment to rate and review our plugin and/or support.

    Hi,
    I’m new to the plugin, and I’m not a novice dev, and I’ve struck exactly the same issue, same error message.

    I’m trying to generate both a popup and trigger button on the fly. The popup is not pre-defined in the popup list (and I couldn’t see anywhere in the docs that this was stated).

    Trigger shortcode:
    [popup_trigger tag='button' id='new-enquiry']<li><span class="title">9ct</span> - <span class="price">$1,490</span></li>[/popup_trigger]

    Popup shortcode:
    [popup id="new-enquiry" theme_id="3098"][gravityform title='false' description='false' ajax='true' id='1'][/popup]

    rendering these gives me the buttons, as expected, and I can see the popup, with the gravity form inside it, hidden in the DOM.

    With no other popups present on the page (apart from the one defined by the shortcode), clicking a trigger button does nothing – assume this is because the relevant JS is not loaded?

    If a pre-defined popup is in the DOM, with its ID targeted by the trigger buttons, it works. If it has the same ID as the shortcode generated one, then it shows (not the shortcode one).

    But if the button targets the shortcode generated popup only, clicking the button gives the same JS error.

    In site.js on line 1182:

    if (settings.mobile_disabled !== undefined && settings.mobile_disabled) {

    settings is undefined which means $popup.popmake(‘getSettings’) is returning nothing.
    I’m stumped. Unsure if I’m outside the bounds of the plugin content.

    As an aside, I tried turning on debug, but I get a different console error as the page loads:

    `
    case “click_open”:
    pum_debug.click_trigger(t, o.settings),
    console.log(i.label_cookie, o.settings.cookie.name)
    }`

    cannot read property ‘name’ of undefined

    • This reply was modified 4 years, 6 months ago by hughc.
Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Post Popups not working anymore ?’ is closed to new replies.