Support » Plugin: NextScripts: Social Networks Auto-Poster » Post ONLY never autoposted posts – in different cronjob

  • I have one question about the repost cronjob.
    I set 2 cronjobs, one for twitter account and one for facebook account.
    If I flag the option “Post ONLY never autoposted posts” in both cronjobs, and the post id #1234 is posted on Twitter, it will never be posted on Facebook, is it correct?
    If I DO NOT flag the option “Post ONLY never autoposted posts”, maybe one post will be posted twice, in the same social.
    I need two cronjobs because I don’t want to post on Facebook and Twitter the same post at the same time.
    Any suggestion about other situation of different cronjobs for different social networks?
    With 158 post, the possibility to repost the same post in the same social is little or big?
    Thank you in advance
    Melania

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author NextScripts

    (@nextscripts)

    “Post ONLY never autoposted posts” will make sure each WordPress will be autoposted only once. It doesn’t matter what network or how many networks.

    Another checkbox “Post each post only once” (It’s available only with “Random”) will make sure that WP post will be used only once by that particular Reposter.

    Hi @melabyte & @nextscripts,

    I also had the idea to set different cronjobs for different posting-actions and try to figure out how this is done.
    In need a cronjob which triggers only publishing wordpress-posts and the autoposting-action.
    And then several cronjobs who trigger different-reposting action.

    Which .php – files has to executed by the cronjob to trigger the different actions?

    Currently my cronjob is running wp-cron every five minutes, but than also the reposter is executed every 5 minutes, thats my problem I need to resolve – I already opened several tickets on that, but never got any answer.

    Thanks you for your help.

    Plugin Author NextScripts

    (@nextscripts)

    Please setup your cron like this:
    http://www.nextscripts.com/tutorials/wp-cron-scheduling-tasks-in-wordpress/

    Do not set it multiple crons, do not set it to “every 5 minutes”.

    Set it every 1 minute. Let the WordPress decide for itself if it has to execute something.

    @nextscripts:
    Thank you very much for the fast answer.
    Can you please tell me what makes the difference between 1 and 5 minutes?

    Actually it seems to work, but thats what I thought the last times too, when the cronjob was every 5 minutes and than the reposter on a certain point started to spam all my networks every 5 minutes with new posts.
    So I’m really afraid now and need to know why this could help.

    Another question: Posting to LinkedIn Pulse dosn’t show the image. I have first to edit the LinkedIn Post and chose the smaller image-format, than the image show up. Any concerns about that?

    And I never get any answer in the nextscripts-forum or for my tickets, so I had to register an account here only for getting in touch with you. I shouldn’t be like that – specially if the solution is really that easy!

    Thanks for your help again!

    Plugin Author NextScripts

    (@nextscripts)

    1. WP Cron is internal WordPress service that processes all scheduled tasks. If you don’t have anything scheduled for this very moment – it just does nothing.

    If you set it to run every 5 minutes it will execute tasks that were suppose to be executed during the last 5 minutes. That could take resources and produce flood. It’s better to run it every minute and let WordPress do do its job.

    2. How big are you images?

    @nextscripts

    1. sorry, I don’t really get that, just to make sure you understand me:

    I use a cronejob who looks like this an gets executed every minute now:
    http://www.nextscripts.com/tutorials/wp-cron-scheduling-tasks-in-wordpress/

    And I set the reposter to get executed every 2 hours. I set the plugin on not to use WP-Cron.
    Instead the plugin posted a post every 5 minutes (when the cronjob was still on every five minutes), now on every minute it seems to work, but the problem is sometimes the reposter takes the settings of wordpress (every 2 hours) and sometimes it was posting every 5 minutes then, which is a huge problem – I was blocked by stumbleupon for example. But a reposter who posts every minute would be worse…
    So are you sure it works with the 1-Minute-Setting that reposter posts every 2 hour?

    btw. there was another issue, sometimes the reposter didn’t save the custom fields.. it appeared when I tried to repost new posts… I reported that too and never get any answer.

    2. My images are 910px big… when I edit the linkedin-pulse posts I can see the stretched image, but they don’t appear in the published linkedin-pulse-post. Is there any way to fix that? I don’t want to use images who are that large…

    And is there any way to have neither Excerpt nor Fulltext, but something in between, like the first 5 pargraphs?

    Thank you!

    Plugin Author NextScripts

    (@nextscripts)

    1.

    1.1
    Please go to the Log/History page and check only “All Cron Events” checkbox.

    You should see ONLY crons executed from WGET or Mozilla every one (or 5 in your case) minutes. If you see nothing at all, calls from “WordPress/4.x.x” or calls made at irregular time intervals, your cron is not set correctly.

    1.2
    Please let me know what do you have in the log right after the reposter that you set to post every two hours posted every five minutes.

    2.
    2.1 I am not sure I am following. You see image in linkedIn, but it doesn’t appear in the post? How is that?

    2.2 %ANNOUNCE% – Inserts the text till the <!–more–> tag or first N words of the post. N could be set in the settings.

    @nextscripts
    Thanks.

    1.1. The Cronjob/Cronevent is perfect. Its allways as follows – I cannot post more as they don’t like logfiles posted here. And if I don’t follow the rules they delete my comments – thats why I need another way to communicate with you (and I mean getting support like here, not once or only every 4 weeks or never).

    [2017-12-05 08:22:09] – [Cron Request]- 54.43s after the previous one. | Cron called from 176.28.36.18 (Mozilla/5.0 (Windows NT 6.1; WOW64))

    1.2. I posted for you the whole logfile with cronevent last week
    in Ticket [Ticket#NXS446832] – and I can send it via eMail.
    After the reposter action I had this:
    [2017-11-27 19:26:27] – [Cron Request]- 245.18s after the previous one. | Cron called from 176.28.36.18 (Mozilla/5.0 (Windows NT 6.1; WOW64))

    2.1. I have no idea how that can be. I see the large image on the edit screen, there is an option to make it smaller, when I do that it works. I can give you access to my LinkedIn account (via eMail) but maybe you can also try that by yourself?

    2.2. Thanks, I will have a look.

    Thanks for your answers!

    @nextscripts

    Did you get my answer? Did you have a chance to check the logfile?
    I still don’t know why the reposter runs so often and I’m desperatly looking for helpt.

    Its great you made a new release; Just recently I was promised that the bug posting to Xing Groups and some minor changes would be fixed in the next release – and they are still there.

    Thanks for your help!

    Hi,
    I tried it out again:
    While it seems to work only with twitter, the reposter got executed every minute when I tried to post in all networks.

    I opened [Ticket#NXS298338] to post the whole logfile with cronevents to show you how it looks like.

    I would go back to my idea to have different cronjobs for different autoposter actions – how can I do that please?

    Do I get any answer on this issues I reporting for weeks, pleas?

    Thank you for your help!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Post ONLY never autoposted posts – in different cronjob’ is closed to new replies.