Support » Networking WordPress » Post not found, but it has been published.

  • Resolved candanosa



    I’m having a problem with my posts not being found. They work fine on my main site, but they don’t on the two other sites on my network. I’m running on Multisite. The feature image shows up fine on the front page and even the text, but when the article is selected, I get this:

    “Not Found
    Apologies, but no results were found for the requested archive. Perhaps searching will help find a related post.”

    I don’t have any pluggins runing on the two sites that are not running on the main site, which is working just fine. Please help me fix this. Thank you.

Viewing 15 replies - 1 through 15 (of 16 total)
  • Bump removed.

    Can you link to your site?

    Thank you.

    My site is
    Im the main site works fone, but the “cosplay” and “life” are having the post problem. works fine for me. does not. Actually looks like none in life are working….

    Are you running any caching plugins?

    can you look in the admin area of /life/ and see if any posts are listed?

    @ipstenu, I had installed W3 but uninstalled it shortly aftwerwards. Then I did the same for Super Cache. Both were uninstalled shortly afterwards as my website would go blank.

    @andrea_r, Yes. They are listed. I can even edit them and work with them, but if I click to preview the post, I get the same “not found” message.

    Thank you both for your time.

    If the /life/ post data is being retrieved and displayed successfully on the home page, but not on the individual post’s page, that may indicate something wrong with the theme script used to display it. Do /life and /cosplay use identical themes? Might be some mileage in comparing them…

    Yes, all my pages use the same theme.

    Try resaving your permalinks. Just go in to the permalink page and click save.

    Thank you, Ipstenu!
    That solved it.

    Thank you all for your time.

    Hi, I am having the same problem but no luck. Permalinks are on default and tried to resaving it. All plugins are deactivated. Posts are publish when I create one.

    This happens when I try to change a theme. If I will use the twentyten theme, post are displayed but when I switch to other theme, post are not found although I could see in the sidebar that there are recent post.

    What else can I do about this?

    Any ideas is much appreciated! Thanks.

    Link to your site? And can you activate the non working theme? Is it a specific theme that doesn’t work, or just any other theme besides the default?

    Hi, thank you for your reply.

    For now I cannot post the link because I switch the theme to twentyten because of the issue of the current theme. Yes, I can activate it. It is a theme copied from another wordpress site. That theme is working in the other website. When I copied it to the new site, it now cause the not found post.

    In twentyten theme it was okay. The post are displayed.

    Then it;s a problem with your theme and you need to contact the theme author.

    ProTip: If a thread is marked resolved (or is over a month since last reply), make your own topic 🙂

    I’m having problem with my post not being found. while I was about to start a blog. I get this ;

    Not Found
    Apologies, but no results were found for the requested archive. Perhaps searching will help find a related post.

    my site:
    What should I do that where I was a beginner.Thanks

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Post not found, but it has been published.’ is closed to new replies.