Support » Fixing WordPress » Post-new.php is blank for both new posts and new pages in 3.0

  • I recently updated to 3.0 automatically. When I click “Add New Post” I get a blank white screen. I get the same thing when I click “Add New Page.” Furthermore, the editor does not load in Quick Press on the dashboard. To the visitor the web site looks fine. The only problem is when I attempt to add a post or page.

    I’ve tried the following:

    1. Disabled plugins
    2. Reset plugins
    3. Switched themes
    4. Downloaded WP 3.0 and replaced WP-Admin and WP-includes folders
    5. Repaired tables in database

    When I originally updated automatically is got stuck and disabled my plugins. I refreshed and it looked fine. When I noticed the aforementioned issue I re-installed automatically before trying steps 1-5. I’ve searched the forums and haven’t found help. Please help.

    Thank you in advance

Viewing 12 replies - 1 through 12 (of 12 total)
  • I have the exact same problem and I have tried all of the above as well as increasing the memory in wp-config.

    Any help would be great, thanks.


    I have the same issue, tried everything Arnstein did, and have a trouble ticket out with Earthlink – as they are my host, and host Arnstein, too. Anyone else with the same issue and on earthlink? The trouble ticket is a “post-new.php” issue. I was told it takes them 24-72 hours to get back about things. I called it in a day ago. I think, Arnstein did, too.

    The instructions earthlink had from WP was for us to – update plugins, disable plugins, do the install.

    This doesnt work on this issue BUT it does work on the other issue I had, which was images would fail to load into the media gallery. I would get a blue square and a ?. Disabling plugins does cure that.

    I can edit old posts, comments can be made, etc.

    This post-new.php issue only affects:

    1. Quickpress fails to load

    2. Add new post (leads to blank white page)

    3. Add new page (leads to blank white page)

    I will come back to this thread when I hear from earthlink.

    I use Graph Paper Press themes – Modularity & F8.

    It isn’t the themes.



    I am suffering same problem (have a separate thread going. -It happens I am also using Earthlink as a host. Seems like that is a common theme between us. Anything from Earthlink?

    I am still waiting to hear from them. Please call Earthlink webhosting support and explain that there is already a trouble ticket on it – that the issue is wp-admin/post-new.php related and affects adding new posts, pages and also QuickPress….and 3.0 related. The more of us that call it in – the better 🙂
    I will post here and also make a new thread when i get an answer …

    who ever hears back first and gets it fixed…let us know !!!


    bump ! Still havent heard back from earthlink

    I’m in the same boat.

    Hosted on Earthlink, checked every damn plug-in/theme related solution and those failed. My .htaccess is blank, permalinks normal, yada yada yada. This is a completely fresh install, new database and everything, done just like every other install I’ve ever done. Only thing that is different is Earthlink and 3.0. I’m guessing Earthlink has some PHP thingy turned off or something. I contacted their support about it, to no avail. Please let me know if you guys find a solution, thanks!

    oh yeah, in case any of you are PHP geniuses, here is what earthlink is providing on the server:

    Hi Jbnla

    Earthlink has access to my file manager, databases, et al.

    They are aware of the issue and I expect to hear from them, this week.

    I use Graph Paper Press themes.

    My .htaccess looks like this

    ‘AddHandler php5-script .php
    # BEGIN WordPress

    # END WordPress’

    Before the 3.0 upgrade, it just had

    ‘AddHandler php5-script .php’

    These came with the upgrade…

    ‘# BEGIN WordPress

    # END WordPress’

    removing or adding them back doesn’t change the issue.

    This is what my post.php file looks like….

    [Code moderated as per the Forum Rules. Please use the pastebin]

    post-new.php as seen on earthlink server

    post.php as seen on earthlink

    I’m on the phone with Earthlink right now.

    Please continue to hold…Call center is based in India.

    Asked for my WordPress password and now holding for another few minutes.

    Took all my info and said they are going to get the “engineers” on the problem. Starting a new ticket and telling me it’s going to take 48-72 hours.

    Meanwhile I am saying goodbye to Overpriced Earthlink hosting and transferring my site. I’m not paying my outstanding bill, either. They made me waste a whole day trying to figure this out when it was all on their end.

    For Earthlink issues with creating a post, see:

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Post-new.php is blank for both new posts and new pages in 3.0’ is closed to new replies.