Support » Plugin: Yoast SEO » Post Meta Description Not Showing Up on Facebook

  • Resolved ilanaguttman

    (@ilanaguttman)


    If I try to share a post such as https://www.irgwebsites.com/get-facebook-traffic/ the custom meta description added in the field generated by the Yoast plugin does not show up on Facebook. Instead it pulls in the sitewide meta description that I entered in the general SEO settings.

    It is showing:
    <meta property=”og:description” content=”Keeping your WordPress core files, plugins, theme up to date, secure and working smoothly. WordPress bug fixes, custom development, SSL installation, in your back pocket.” />

    when it should be showing what Twitter is correctly pulling in:
    <meta name=”twitter:description” content=”Marketing expert Shari Wright Pilo shared her top tips to get traffic to your business on Facebook to a women’s business networking group in Jerusalem.” />

    I ran the debugger tool and the only warning is The following required properties are missing: fb:app_id

    I searched extensively in the Yoast Help Center and ran the debugger and identified that the cause is neither the plugin or any other plugin, nor the theme. Even with a default theme and all plugins deactivated I still have this problem.

    I also was unable to follow the Yoast article that said to generate a Facebook app and to enter the ID under SEO > Social > Facebook, because there simply is no such field there. Maybe I need Premium in order to see this field, but none of the help articles, included those written in the last 2 weeks, indicate that it is.

    I don’t know what to do. Please help!

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 20 total)
  • What kind of SSL do you have, when did you install it, did you redirect your root?

    Thread Starter ilanaguttman

    (@ilanaguttman)

    Thanks for your reply. I have SSL through Let’s Encrypt. I installed it probably about a year ago.
    “did you redirect your root?”
    >> I just found a setting in Cloudflare to redirect all http requests to https

    I didn’t think of that.

    I should mention that I flushed my server’s master cache.

    Still seeing the same problem.

    Plugin Support Rumejan Barbarona

    (@onlyincebu)

    I checked the source code of the URL you provided, https://www.irgwebsites.com/get-facebook-traffic/, and it appears that there’s another set of open graph meta tags that are not generated by Yoast. Please disable other plugins or theme features that may generate those.

    Thread Starter ilanaguttman

    (@ilanaguttman)

    @onlyincebu Please see my original post. I determined that it’s not being caused by another plugin or theme. I tried deactivating all other plugins and I still see the same result. I just tried again for good measure.

    • This reply was modified 3 years, 7 months ago by ilanaguttman.
    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    First thing first your page has a duplicate set of the social open graph meta. Please, disable the duplicate set of meta description to ensure Facebook scrapper scrape the information from Yoast SEO generated open graph meta.

    Once you disable the duplicate set of social open graph meta, can you please remove the site-wide meta description from the Yoast SEO social settings to check whether the Facebook specific open graph meta pick the correct meta description?

    Thread Starter ilanaguttman

    (@ilanaguttman)

    Yes, I understand that there is duplicate meta data and that it is pulling in the wrong version. How do I get rid of the wrong one?
    Where is the site wide met description?

    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    You can find the site-wide description directly from the Yoast SEO -> Social -> Facebook (tab).

    Thread Starter ilanaguttman

    (@ilanaguttman)

    @mazedulislamkhan
    I do not see that there.
    I see only:

    • Add Open Graph meta data: Enabled / Disabled
    • Default settings

      Image URL:

    • Save Changes button
    • Ad for Yoast Premium

    That’s it!

    • This reply was modified 3 years, 7 months ago by ilanaguttman.
    Plugin Support Michael Tina

    (@mikes41720)

    We reviewed the URL https://www.irgwebsites.com/get-facebook-traffic/ and we are certain that there are multiple open graph tags for your title and description, one being generated by the Yoast SEO plugin, and one being generated by another plugin, theme, or custom code.

    We recommend you remove the unwanted code or deactivate the plugin causing the duplicate set of open graph tags and run it through the Facebook Sharing Debugger Tool so that it will pick up the correct open graph tags generated by the Yoast SEO plugin.

    Please see the screenshots:

    og tags from Yoast SEO plugin — https://snag.gy/SDIC4q.jpg
    og tags from some other source — https://snag.gy/5xyjH6.jpg

    Thread Starter ilanaguttman

    (@ilanaguttman)

    @mikes41720 I appreciate your taking the time to respond, but you are saying the same thing that others before you have said.

    I have already tried deactivating all other plugins besides Yoast and switching to a default theme and I STILL see this. The error that I see on the Facebook Sharing Debugger Tool is missing: fb:app_id
    Even if I do create a Facebook app, there is no where to enter it on Yoast settings as far as I can tell.

    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    We looked at your page again and we can confirm that no duplicate social meta appears now.

    In regards to the Facebook APP ID and Meta Description, we think the issue is specific to your site. We’d need to investigate further but are unable to do so on these forums. You can purchase Yoast SEO Premium and receive our Premium email support and we can help you further.

    Thread Starter ilanaguttman

    (@ilanaguttman)

    Yes @mazedulislamkhan, I fixed it on my own. There was something else that no one else caught because everyone here kept regurgitating the same information about what to check even though I reported that I already conducted all of those tests.

    Thank you for following up though.

    I would appreciate it if someone could respond to the fact that settings indicated above simply do not appear.

    For example: @mazedulislamkhan You can find the site-wide description directly from the Yoast SEO -> Social -> Facebook (tab).

    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    If the site-wide social description option isn’t appearing in Yoast SEO settings, this means you’re using a static page as the front page. Therefore, you will need to edit the meta description by editing the front page directly under the Yoast SEO meta box social settings.

    Thread Starter ilanaguttman

    (@ilanaguttman)

    Oh, it doesn’t really make sense to me that the homepage meta description is also the “site wide” one.

    I am having a similar problem – description shows fine in Google, but not in Facebook. There is a duplicate set of og: meta properties under <!– For iPad Retina display –> that is listing the information I don’t want. What could be creating this? How can I get rid of the duplicate?

    • This reply was modified 3 years, 4 months ago by sharnika.
Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘Post Meta Description Not Showing Up on Facebook’ is closed to new replies.