Support » Plugin: Post Lockdown » Post Lockdown stopped working

  • Resolved vyxer

    (@vyxer)


    I’ve been working with this plugin for some time and now, suddenly, it stopped working. I’n in WordPress version 5.6.1. Plugin version 3.03. I can’t lock down new posts or unlock those that were locked down before. Any idea?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author andyexeter

    (@andyexeter)

    Hey @vyxer,

    Whenever a new version of WordPress is released I test the latest version of the plugin on a clean install before updating the “Tested up to” tag. I noticed no issues during this testing.

    I just tested again on a clean install and everything is working as expected. This means there is either another plugin, some theme code, or a browser extension causing this.

    Can you think of any of the above that you have recently added? It may be worth trying to disable these one by one and seeing if you can find out which one is the culprit.

    As a guess, it sounds like something is stopping the PostLockdown JavaScript from loading. Do you see any errors in the developer console?

    • This reply was modified 8 months, 1 week ago by andyexeter.
    Thread Starter vyxer

    (@vyxer)

    Hi Andy,
    Thank you for your quick reply.
    I uninstalled version 3.0.3 and installed 2.0.3, and this version works fine.
    Some days ago, I added the Enable jQuery Migrate Helper plugin, that’s the only new thing. But Post Lockdown (v 3.0.3) isn’t working, even with Enable jQuery Migrate Helper inactive.
    Can’t see any error in the developer console.

    Plugin Author andyexeter

    (@andyexeter)

    Hey @vyxer,

    I’ve just installed that plugin on a clean install of WordPress and am unable to replicate your issue.

    My install is using the Twenty Twenty-One theme and contains only two plugins: Enable jQuery Migrate Helper and Post Lockdown.

    On the jQuery Migrate helper plugin settings page, I have tried with both the “Default from WordPress” and “Legacy-1.12.4-wp” versions of jQuery and the Post Lockdown settings page works as expected.

    Within the developer console, what does jQuery.fn.jquery show for you? It should be 3.5.1 on WordPress 5.6.

    I’d be happy to login and take a look if you wanted to set me up with a user account. You can send the details to my email: andy@andypalmer.me

    Thread Starter vyxer

    (@vyxer)

    Well, you won’t believe it. I updated the plugin (from 2.0.3 to 3.0.3) so that you could check, and now it’s working again!
    If it fails again, I’ll tell you.
    Sorry for the inconvenience. And thanks again for your help.

    Plugin Author andyexeter

    (@andyexeter)

    How odd! I wonder if your original 3.0.3 files had been corrupted somehow, which was causing the JavaScript to not load correctly.

    I’m glad you got it working šŸ™‚

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Post Lockdown stopped working’ is closed to new replies.