Support » Fixing WordPress » Post list does not show up on post page

  • Resolved nicoandthepage

    (@nicoandthepage)


    Hello everyone!

    I am new to the world of wordpress and have just set up my website with the Livro theme. I have dedicated a page named “Posts” to show a list of my posts.
    The website is called nicoandthepage.com
    When I am in the editor mode everything is fine and the post list shows up with excerpts of the posts content and the featured image.
    However, when I switch to actually view my website after having saved and updated everything the “Posts” page appears to be empty and just shows the header and footer.
    I have tried purging my Cache because some people in the forum recommended it on similar issues but it did nothing.
    Can anybody help?

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Hi there,

    Have you set that “post” page to be the Posts Page under Settings ->Reading ->Your Homepage display a static page drop down menu?

    Thread Starter nicoandthepage

    (@nicoandthepage)

    Hello franzaurus!

    Thank you for your answer. Yes, I have set the page to static and have set my posts page to be the posts page in the drop down menu. Unfortunately nothing has changed.

    Hi @nicoandthepage
    Can you share a few screenshots with us?

    1. Settings ->Reading page
    2. Your Posts lists
    3. How is looking when you’re in the editor mode

    Hi nicoandthepage,

    I’m not able to recreate your empty Posts Page in Livro, but I’m too experience view discrepancies in editor mode and in public viewing mode, e.g the feature images that show/no show.

    But since Livro is a Full Site Editing theme, you can try to override the Post Page by adding a Blog Posts block into it. There’s an awesome plugin that contains such block, namely WordPress.com Editing Toolkit. https://wordpress.org/plugins/full-site-editing/

    Please have a look and see whether it can solve your problem.
    Cheers.

    • This reply was modified 3 months, 2 weeks ago by franzaurus.
    Thread Starter nicoandthepage

    (@nicoandthepage)

    Hi @franz00
    I have tried your plug in and it is very nice with all the options it gives for a blog post. But unfortunately even when I override the posts page by adding a blog post block nothing changes when I go to the “view page”. Again in the editor everything is fine and I can see the blog posts with featured image and excerpt but when I go to view the post page on my website then it is completely empty and only shows the header and footer.

    Thread Starter nicoandthepage

    (@nicoandthepage)

    Hello @hmbashar
    Thank you for your answer.
    How would I go about providing a screenshot in this forum? Sorry I am unsure about how it works.

    Hi @nicoandthepage
    You can use any type of screenshot service like https://app.prntscr.com/en/index.html or you can upload on dropbox and give that link.

    Hi @nicoandthepage,

    Perhaps you’d like to consult this troubleshooting steps? That might be able to give you some insight.

    Hope this helps.

    Thread Starter nicoandthepage

    (@nicoandthepage)

    Hi @franz00

    Thank you very much for that!
    I have now changed themes and my posts and featured images finally show up normally.
    So it seems to have been an issue with the livro theme.

    Thank you very much for your help.

    Hi @nicoandthepage,

    No, problem. Glad that helps. Good luck with your site. 🙂

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.