WordPress.org

Support

Support » How-To and Troubleshooting » Post Links not working

Post Links not working

Viewing 8 replies - 1 through 8 (of 8 total)
  • Check your single.php file . Try restoring any old backups of the single.php file.

    Irfan
    [signature moderated]

    tried this.. restored the original and still have the problem!

    Try changing the permalink structure.

    “Settings”->Permalink to some other structure.http://www.example.com/2011/08/04/sample-post/

    Irfan

    Tried… still no luck. Was working fine yesterday and all I have changed since then is installing the trick ttffilesplug in

    i am trying to use the ttf titles plug in

    i have added this code to where the problem is happening …

    <div id=”post-<?php the_ID(); ?>” <?php post_class(); ?>>
    <h1 class=”entry-title”><?php the_title();>”<?php if (function_exists(‘the_ttftitle’)) { the_ttftitle($before=””, $after=””, $echo=true, $style=”HouseScript”); } ?></h1>

    could this be the problem… it seems the the links are linking to the correct place but the post isnot displaying?

    also when i go to a link like this:

    http://dubsmugglers.com/test/wordpress/2011/08/04/

    all the posts from that day will show, but if you want to view a specific post then it wont show… doesn’t go to an error page just a white blank screen…

    is there anyway to make the post unclickable?

    edspeed

    This is what i got from ttf titles plugin home page:

    There are two template tags you can use to actually make the text images show up:

    <?php the_ttftitle(before, after, display, style, overrides); ?>
    <?php the_ttftext(text, style, overrides); ?>

    The tag ‘the_ttftitle’ can be used to replace ‘the_title.’ The first three arguments for the_ttftitle are the same as for the_title. The tag ‘the_ttftext’ can be used to turn any chunk of text into an image.

    The ’style’ argument should be the name of a style defined in the ‘Styles’ tab. You can use ‘null’ for this argument to use the default style.

    The ‘overrides’ argument can be used to override any of the parts of the style. It should look like: name1=val1&name2=val2… The variables you can override are:

    so i think you have to use the_ttftitle() instead of the_title(). Don’t keep both of them together.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Post Links not working’ is closed to new replies.