Support » Plugins and Hacks » Post Levels ~ Bad Bad Baby for Me!

Post Levels ~ Bad Bad Baby for Me!

Viewing 14 replies - 1 through 14 (of 14 total)
  • Make sure you’re setting the post status to “Private”

    Yes. Everything is correct. It still shows.

    Have you set the post_level custom field? Are you logged in to your site (because if so you’ll see your private posts)


    Disable the plugin, do you still see the posts? If not, then I’m completely stumped.

    Well, if you are login already then you will see the post. Logout of the WordPress you will not see the posts.

    I am aware of that. thanks.

    I’ve got the same problem and I definitely know its not caching as I use seperate machines to verify.

    I thought that ‘private’ was merely a backup and that the post should not show regardless as long as the plugin is enabled?

    Post levels doesn’t work on public posts, only private. This ensures that the protected posts won’t be shown if the plug-in is disabled. This is a common source of confusion for people, but it’s more secure.

    I’m confused by Tek’s problem, since he’s saying that the posts are hidden when the plugin is disabled but not when it’s enabled. Unless the post_level parameter is incorrectly set, this is an unknown bug.

    I’ve hacked the edit page to give me a nifty little drop down box which defaults to level 2 instead of having to add post_level each time.

    But is there someway I can get it to show in the archives and calendar?

    Sorry not very good at all this php stuff….

    You’ll have to hack into the PHP source and find where they do the archive / calendar querying. Hopefully future versions of WordPress will provide the hooks required to be able to do this within a plugin.

    No. The posts are never hidden.

    If the posts are never hidden, then most likely your post status is set to Public, not Private.

    DISREGARD: I posted before searching. My aplogies

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Post Levels ~ Bad Bad Baby for Me!’ is closed to new replies.