WordPress.org

Support

Support » Themes and Templates » [Resolved] Post is all one Link

[Resolved] Post is all one Link

  • I am having this issue with a wordpress theme.
    The full text of each post is always linked as a whole back to the index page. Here an example: http://www.iropartners.at/?p=4366

    SINGLE.PHP CODE_

    <?php get_header(); ?>
    
    	<div class="content">
    
    	<?php if (have_posts()) : while (have_posts()) : the_post(); ?>
    
    		<div class="post_inserat" id="post-<?php the_ID(); ?>">
    			<h2><?php the_title(); ?></h2>
    
    			<div class="entry">
    
    				<?php the_content('<p class="serif">Read the rest of this entry »</p>'); ?>
    
    				<?php wp_link_pages(array('before' => '<p><strong>Pages:</strong> ', 'after' => '</p>', 'next_or_number' => 'number')); ?>
    
    			</div>
    
    			<div class="postmetadata">
    					<?php if( function_exists('the_tags') )
    						the_tags(__('Tags: '), ', ', '<br />');
    					?>
    
                        <div class="sharezone">
    
                        <a name="fb_share" type="icon_link" href="http://www.facebook.com/sharer.php">Teilen</a><script src="http://static.ak.fbcdn.net/connect.php/js/FB.Share" type="text/javascript"></script>
    
                         | 
    
                        <?php if(function_exists('wp_print')) { print_link(); } ?>
    
                        </div>
    
    					<?php edit_post_link(__('Edit'), '', ''); ?>
    			 </div>
    		</div>
    
    	<?php endwhile; ?>
    
    		<div class="navigation">
    			<?php previous_post_link('« %link «') ?>
                <br />
    			<?php next_post_link('» %link »') ?>
    		</div>
    
    	<?php else: ?>
    
    		<p>Sorry, no posts matched your criteria.</p>
    
    <?php endif; ?>
    
    	</div>
    
    <?php get_sidebar(); ?>
    
    <?php get_footer(); ?>

    Cannot find the bug till now …

Viewing 5 replies - 1 through 5 (of 5 total)
  • esmi

    @esmi

    Forum Moderator

    It could be a CSS issue. Have you checked using Firefox with the Firebug add-on or whatever developer tool is available in your web browser?

    thanks for the tip esmi ! tried it now with various different tools but could not find it so far … do haveyou any other ideas ?

    Sill couldnt figure out the bug.
    Here is another example: http://www.iropartners.at/?p=4911 (code above).
    Thanks for your help !

    Michael

    @alchymyth

    Forum Moderator

    there is some mess with the linked header banner; there is a second unclosed link tag without content;

    from the html of your posted link in the browser:

    <div class="banner_center"> <a href="http://www.iropartners.at"><img src="wp-content/themes/iropartners_wordpress/images/ip_logo.png" width="235" height="60" alt="Iro&Partners" /></a> <a href="http://www.iropartners.at/">

    please look closely into header.php or post the code here.

    THIS IS IT !
    Thank You, alchymyth !

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] Post is all one Link’ is closed to new replies.
Skip to toolbar