Support » Fixing WordPress » Post Images Do Not Show Up in Firefox, but Appear in Safari, Chrome

  • Hello,

    When I insert images into posts, the images do not show up when browsing with Firefox. They show up in Safari and Chrome. I have not tried IE.

    You can see this on my most recent post at: http://www.kimberlyfitzsimons.com.

    Can anyone suggest what may be causing this?

    (I just moved from Blogger to WordPress, which is why all of the other photos on the blog work fine.)

    Thank you.

Viewing 2 replies - 1 through 2 (of 2 total)
  • On line 1139 of your theme’s style.css, there is a rule that puts display:block on your post images.

    .blog-content .post-content img {
      display: block;
    }

    This is preventing the images from displaying in FireFox. I don’t know why. This is the first time I’ve seen the phenomenon. You will need to comment out that rule. I’d mention it to the theme developers too.

    I have a similar problem: My first page (www.dragon-a-day.com), which displays recent posts, only shows the image(s) in the most recent post when you use Firefox to view the page, but individual posts display just fine. It wasn’t always like this, but I haven’t changed the theme in over a year… I even searched my code for something like what you found in kimberlychicago’s, but couldn’t identify anything that might be causing FF not to show other images.

    If I should start a separate thread for this problem, I will, but it seemed in keeping with the problem that I’m having.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Post Images Do Not Show Up in Firefox, but Appear in Safari, Chrome’ is closed to new replies.