Support » Plugin: Podcast Player - Your Podcasting Companion » Post images do not appear

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author vedathemes

    (@vedathemes)

    Hi there,

    Thanks for trying Podcast player.

    I have checked your podcast feed. Podcast player fetch the image either from image type enclosure or from itunes image tag. Both of these are not available in the feed.

    Can you add any of the above tags to your feed? It is widely used and should be possible to create with your feed generator.

    Can you inform how you generate your podcast feed? I mean which plugin you use to generate RSS feed? I will try to check and inform how to generate the tag in your feed.

    Thanks,

    Thread Starter senda2020

    (@senda2020)

    Thank you very much for your quick reply,
    At first we did not use any plugin, only the native WordPress generator, which includes the images when “full text” is selected in Parameters > reading.

    Then we have tried RSS Aggregator by Feedzy plugin: https://es.wordpress.org/plugins/feedzy-rss-feeds/

    When selecting the feed, the images appear but not the enclosure tag of images that you comment.

    We have removed it finaly, and we have added this plugin and followed its instructions: https://www.danielnabil.com/blog/como-anadir-miniaturas-imagen-feed-rss-wordpress/

    But none of the solutions shows the image in the widget player. Are there any special widget settings? For example, show header information or other?

    Thank you

    Regards

    Diego

    Plugin Author vedathemes

    (@vedathemes)

    Hi there,

    1. If you want to create the best possible and error free RSS feed specifically for your podcast, you should use Powerpress plugin. This is the standard plugin for creating podcast feeds with WordPress.

    2. If you want to use native WordPress generator only (The one you were already using), following steps should help you to add image enclosure,
    2a. Make sure that you have set thumbnails (Featured Images) for your posts.
    2b. Use simple method explained on this link (https://mamacatdev.com/add-featured-images-wordpress-rss-feed/).

    Please inform if more help is required on this.

    Thanks,

    Thread Starter senda2020

    (@senda2020)

    Hi, thanks for the advice. We have tried using the native Wodpress system and marking the full text. The images appear within the description, but not in the header:

    Not featured image in header

    We have tested with the plugin that you recommend: Powerpress. There are many configurations, we do not know if we have done it well (we would need instructions). Anyway, only the same Powerpress image is shown, not the featured post image:

    Image of Powerpress

    Any other idea?

    We show you how we configure the widget:

    Widget configuration

    Thanks

    Regards
    Diego

    • This reply was modified 2 years, 6 months ago by senda2020.
    • This reply was modified 2 years, 6 months ago by senda2020.
    • This reply was modified 2 years, 6 months ago by senda2020.
    Thread Starter senda2020

    (@senda2020)

    Hi,
    Method 2 doesn’t work either. We’ve temporarily disabled Powerpress and inserted the snippet into the theme’s function.php file, but nothing seems to change. Clear cache on both websites, browser history …

    Thanks

    Regards
    Diego

    Plugin Author vedathemes

    (@vedathemes)

    Hi there,

    Thanks for the detailed explanation.

    I have checked that now your podcast is showing one header level image (https://wee-bear.jurassic.ninja/2020/05/12/hello-world/).

    Have you set featured image for your podcast episode post?

    Please try previously mentioned steps after setting up the featured image. It should solve the issue.

    Please inform if you already setup featured image and still can’t see proper results. We will try our best to make it work.

    Also, make sure that you update (refresh) the podcast feed using following steps,
    1. Go to WordPress Dashboard > Settings > Podcast player
    2. Look for “Feed Updation Tool” on the right sidebar
    3. Enter your feed URL and select “Update Only”
    4. Click “Update Now” button

    Thanks,

    • This reply was modified 2 years, 6 months ago by vedathemes.
    Thread Starter senda2020

    (@senda2020)

    Hi there,

    I will try to answer your questions:

    I have checked that now your podcast is showing one header level image (https://wee-bear.jurassic.ninja/2020/05/12/hello-world/).
    Yes, but this we had tried yet. What we need is each featured image from each episode, not a header still image (that works)

    Have you set featured image for your podcast episode post?
    Yes of course. Each post has its title + text + audio + featured image
    Show capture

    Please try previously mentioned steps after setting up the featured image. It should solve the issue.
    Here you can see the featured image and the creation order of the thumbnail:
    Show capture

    Please inform if you already setup featured image and still can’t see proper results. We will try our best to make it work.
    If it refers to whether we add the featured image in each post … yes. This image is used for many other measurements too and regenerated:
    Show capture

    Also, make sure that you update (refresh) the podcast feed using following steps,
    OK, we follow the steps, but there are no changes.

    I think we give up 🙁
    We have tried other RSS aggregation plugins and the image does appear (although they do not add podcasts).

    I think we will continue to use its plugin but we will try to go back to when the featured image was displayed within the extended description.

    Thank you for your work, really, but we cannot purchase the PRO version if the featured images of episodes on our site do not work for us. If you find a solution later, count on us 😉

    Best regards
    Diego

    • This reply was modified 2 years, 6 months ago by senda2020.
    Plugin Author vedathemes

    (@vedathemes)

    Hi there,

    First of all thanks for your patience. There is no pressing for pro version. I just want that podcast player should work perfectly on your website.

    There is just one problem we have to resolve, make image enclosure available on your feed file.

    I think the snippet on above method 2 (from https://mamacatdev.com/add-featured-images-wordpress-rss-feed/) should work.

    Can you try following sequence,

    1. Disable Powerpress and just use default WordPress feed generator (Method that you were using before)
    2. Apply method 2 as explained above
    3. Clear podcast cache from steps explained below,
    3a. Go to WordPress Dashboard > Settings > Podcast player
    3b. Look for “Feed Updation Tool” on the right sidebar
    3c. Enter your feed URL and select “Update Only”
    3d. Click “Update Now” button
    4. Check again.
    5. If you still find same results, please provide the feed url (I will check the URL)

    Also, if you want me to check on your website (the root cause of the problem), you can provide a temporary access. You can contact me on contact@vedathemes.com for that.

    Thanks,

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Post images do not appear’ is closed to new replies.