Support » Plugin: Atomic Blocks - Gutenberg Blocks Collection » Post Grid excerpt does not work on front end

  • Resolved Melissa

    (@emdashing)


    Hello!

    I recently installed Atomic Blocks and the Atomic Blocks theme. While editing my page, the post grid block looks correct, but when I save and view the live page, the excerpt does not work right. It seems that the excerpt settings for the block are disregarded when there is a <!--more--> in the post.

    I’ve tried disabling all other plugins does not have any affect.

    Can you help?

Viewing 3 replies - 1 through 3 (of 3 total)
  • madison4wpe

    (@madison4wpe)

    Hey Melissa,

    I tried to replicate the issue using the Atomic Blocks theme and Plugin. I made a video demonstrating the application of the <!--Read More--> block along with modifying the Excerpt Length, using the slider tool built into the Block’s Post and Grid Content accordion in the Block options within the Editor.

    The Excerpt length will work in conjunction with the two tools, being the Excerpt Length slider and, while also respecting the presence of a <!--Read More--> block when applied within the default excerpt length boundaries defined in WP of 55.

    Demonstration video here: https://www.loom.com/share/ce71fc3a72384c4984f8710c83747da2

    Let me know if this is beneficial in your troubleshooting.

    Melissa

    (@emdashing)

    Oh gosh, I figured it out. Some of my old posts had a manual excerpt added and I didn’t see it because I’m still not used to the new editor! Argh.

    When I remove the manual excerpt, it all works as expected.

    Thanks for looking into this and I’m sorry to waste your time!

    madison4wpe

    (@madison4wpe)

    Ah wonderful, no waste of time at all. Glad you were able to work it out!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Post Grid excerpt does not work on front end’ is closed to new replies.