Support » Plugin: Essential Addons for Elementor » Post Grid – Differences in preview (since update)

  • Resolved zeronimo

    (@zeronimo)


    Hello,

    first of all please excuse my english. I will try my best.

    I have the following problem:

    I used the Post Grid Widget. EA is up to date.
    Since the last update (5.1.6) the view of the images has changed.
    They no longer fill the space.

    But only in the preview. Everything is shown correctly in Elementor.

    This is how it should be (and it is in Elementor): https://ibb.co/0s85n81
    This is what it looks like in the preview:`https://ibb.co/SfxVyqD

    I hope you can help me. Many Thanks.

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Support Sadman Sakib Nadvi

    (@sadmansakibnadvi)

    Hello there,

    Greetings.

    Can you please share the page link?

    I will check and get back to you as soon as possible.

    Thank you.

    Thread Starter zeronimo

    (@zeronimo)

    Hi!

    I have the same problem after Essential addons plugin update with Post grid element on 2 sites:
    https://www.islamska-zajednica.si/
    https://www.islamska-skupnost.si/

    Also the Load more buttons shows, even if it is disabled in setting for this plugin (I’ve hidden it with CSS). Sometimes post images just don’t show.

    I’m figuring out what to do, please help.

    with regards,
    Urban

    Nevermind, I regenerated the assets under Essential Addons > Tools > Regenerate assets button. I think this fixed the layout problems.

    Urban

    Thread Starter zeronimo

    (@zeronimo)

    Hello, I’m glad it helped you.

    Thanks for the tip.
    Unfortunately it doesn’t solve my problem.

    @zeronimo I checked your code, there is a height:56,25% CSS style inlined on that image.
    <div class=”eael-entry-thumbnail”>
    ABT100796
    </div>

    This is probably some EA addons bug, because I had something similar, but with bottom-padding:56,25%. The author will probably fix it ASAP.

    Meanwhile, you can use something like this in your CSS:
    .eael-entry-thumbnail img{
    height: 100% !important;
    }

    You should change image sizes in Post Grid element to smaller, I have a good connection and I waited quite some time to load them all. You don’t need big images for thumbs here. https://benterode.de/wp-content/uploads/2021/12/ABT100797-scaled.jpg

    Thread Starter zeronimo

    (@zeronimo)

    This is so great! Thank you very, very, very much.

    I’m not that savvy with CSS. Thank you. It works.

    See: https://benterode.de/archiv/luftfotos/

    And thanks for the tip about the pictures. I have now set the preview to 300×300.

    Just perfect. I don’t pay attention to some little things.

    Thank you.

    I’m having this same problem but none of the above worked for me. After doing the CSS change, it seemed fine but then I did a hard refresh and it went back to being small. In my inspect, I’ve found that this:
    .eael-entry-thumbnail {
    padding-bottom: calc(0.1 * 100%);

    has something to do with it but if I change that 0.1 to something larger, the image increases but the ‘read more’ button gets hidden behind it. I’ve also tried the regeneration of assets which did nothing.

    I’m also not using the ‘load more’ button option in there but it shows anyway. I tried creating a new section and re-doing everything but it also doesn’t work. Everything looks fine when editing the page in Elementor.

    Any other ideas here? I can usually fix things with CSS but this one has me stumped! Thanks.

    EDIT: saw this post: https://wordpress.org/support/topic/5-1-6-post-grid-problems/
    adjusting the image height to 197px worked.

    https://christmaspudding.co.nz/ (at the bottom of the page)

    • This reply was modified 3 months, 2 weeks ago by WorkinWP.
    Plugin Support Sadman Sakib Nadvi

    (@sadmansakibnadvi)

    Hello @iguanamom ,

    Greetings. Thanks everyone for contributing. We really appreciate it.

    You can hide the load more button with this CSS:

    .eael-load-more-button-wrap {
        display: none !important;
    }

    Can you please share again what other issues you are facing? I will check and get back to you as soon as possible.

    Thank you.

    @sadmansakibnadvi thanks, I don’t need the button hidden. My only issue was the picture being tiny which I’ve fixed with css but it was never like that before. Might be good to put in a real fix for that.

    Thanks!

    Plugin Support Sadman Sakib Nadvi

    (@sadmansakibnadvi)

    Hello @iguanamom ,

    Greetings.

    Are you using any caching plugin? Would you please try deactivating it and check again?

    Let me know how it goes.

    Thank you.

    @sadmansakibnadvi Hi,

    Not using caching plugin. As you can see in the above posts, others are also having this issue and fixed with CSS.

    Thanks!

    Plugin Support Abid Hasan

    (@abidhasan112)

    Hi @iguanamom @zeronimo @nupy ,

    Thank you guys for pointing out the issue. We’ve found the root cause of this issue.

    Our dev team is working on it and this will be fixed in the next version don’t worry. We’re planning to release this hotfix(both Load More and Image Size issue) as soon as possible.

    Thank you!

    @sadmansakibnadvi Ahhh thank you very much. Glad to see it wasn’t ME for once lol. I appreciate it and will be watching for the update.

    Plugin Support rafinkhan

    (@rafinkhan)

    Hi @iguanamom @zeronimo @nupy,

    We have pushed a new release of Essential Addons today. So, please update your plugin to 5.1.7 version and your issue should be resolved.

    Thank you for your patience.

Viewing 15 replies - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.