Support » Plugin: Nimble Page Builder » Post Grid Appears Inconsistently But Wrong in IE 11

  • Joe

    (@joseph_winn)


    To start, I love the plugin and how it’s made our site so much more dynamic and interesting, not to mention functional. In recent testing, I noticed the post grids used on nearly all our pages appear either in a blown-up single column or a single grid item with corrupted data inside…but only when using IE 11 (Edge and all other browsers are fine…we use Macs, so didn’t have ability to test for this previously).

    Unfortunately, 14% of our visitors still use IE 11 or below. Is this a bug or a known incompatibility? If so, is there a workaround so we can still provide useful pages for users on these older browsers?

    Thanks.

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Contributor Rocco Aliberti

    (@d4z_c0nf)

    Hi Joe,
    thanks for your appreciation! 😀

    Yes, the grid module is not supported by IE11, please see also:
    https://wordpress.org/support/topic/nimble-builder-post-grid-ie-11-issues/#post-11580706

    There’s no workaround at the moment for that.

    Also, could you please elaborate a little more what you mean with corrupted data?

    Thread Starter Joe

    (@joseph_winn)

    That’s a real bummer, since a good minority of our visitors use this browser and will think our site is simply broken. Is there a way to have a different message/content load for their browser?

    When I say “corrupted data”, I mean post content shows up in malformed boxes with text overrunning the boundaries. It either makes one column of large boxes with post content or one small box with one post worth of content. Both are not ideal for viewing.

    Plugin Author Nicolas

    (@nikeo)

    Hello, a patch has been added a few weeks ago to adapt to IE11 as much as possible. But improvements are needed. I re-open this issue.
    Thanks for reporting the problem.

    Thread Starter Joe

    (@joseph_winn)

    Great to hear. When will this be available to users?

    Thread Starter Joe

    (@joseph_winn)

    Is there any update on this patch/workaround for IE 11 or below? I checked and it still loads the same (one post grid item with garbled text or one column with poor formatting).

    Thanks for useful plugin!

    Plugin Author Nicolas

    (@nikeo)

    Hi, still working on it. We’re doing our best to adapt the grid for IE11.
    Thanks

    Thread Starter Joe

    (@joseph_winn)

    Thanks for the reply and update.

    Plugin Author Nicolas

    (@nikeo)

    Hello @joseph_winn, the latest version of Nimble Builder (v1.9.2) implements a compatibility patch for a better display of the grid module in IE11.
    The display is not exactly the same as in other browsers, but posts are now all visible.
    Your feedback would be welcome, thanks !

    Thread Starter Joe

    (@joseph_winn)

    That’s wonderful news! I updated our site and will begin testing when I have the opportunity. Thank you again for following up and staying in touch!

    Thread Starter Joe

    (@joseph_winn)

    I had a chance to look at the site in IE 11 (Windows 10). You are correct, all posts do display. It doesn’t appear to distinguish between grid or list formats (they render the same in IE 11). Would it be possible to have the thumbnail image not take up the entire horizontal width? I understand it cannot match the grid display, but the large images take up a lot of space.

    At this time, I did not find any bugs in that display, however. Thanks again for your work in providing further compatibility!

    Thanks! I know where I went wrong (stupid): I selected the wrong section/column to align vertically to the top (module instead of column). Specifically the middle column is hard to select (best at the bottom).

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Post Grid Appears Inconsistently But Wrong in IE 11’ is closed to new replies.