WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Post gets cutoff when a single quotation mark is used in the body.

[Resolved] Post gets cutoff when a single quotation mark is used in the body.

  • I noticed that in the email body, the first use where a single quotation mark is located, that the rest of the email is cutoff when it’s posted.

    For example: http://thatsgravy.com/studies/2013/blog-posts/equity-dynamics/

    – The blog post gets cutoff at the last word “This dynamic leads to increasing a person”
    – The original text from the email is “This dynamic leads to increasing a person’s net worth much faster than many other investments…”
    – so it cuts off at the character “n” in person.

    I hope this explains the bug, thank you in advance!

    – Ryan

    http://wordpress.org/plugins/post-by-email/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Kat Hagan

    @codebykat

    Hi again Ryan,

    I just tested and I can’t seem to get this to happen. Have you upgraded the plugin to the latest version? Are you connecting via POP or IMAP?

    Also, what version of WordPress and PHP are you running?

    Oh, and one more question – is this email an HTML or plain-text email? (If you’re not sure, let me know what mail client you used to send it and I can tell you how to figure it out.)

    Plugin Author Kat Hagan

    @codebykat

    Oh, I just found it — looks like an issue with “smart” quotes. One second.

    Plugin Author Kat Hagan

    @codebykat

    I believe this to be fixed in the version I just released, 1.0.4b. Please test again and let me know if I’m wrong!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] Post gets cutoff when a single quotation mark is used in the body.’ is closed to new replies.