Support » Plugin: Yoast SEO » Post format archive bug from latest update

  • Resolved George

    (@quantum_leap)



    From latest release:
    7.7.1

    One of teh bug fixes:
    * Fixes a bug where disabling the post_format archive would result in it actually being enabled and vice versa.

    How long has this been there before it was fixed? This is a serious!

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    It looks like the bug was introduced on this pull request and which was merged on v7.0.

    George

    (@quantum_leap)

    Does that mean that from version 7.0 up until 7.7.1 if someone had post_format enabled to be indexed, it would actually be disabled meaning YOAST SEO would instruct search engines not to index?

    Plugin Support Pcosta88

    (@pcosta88)

    Hi,

    Yes. There was an issue in v7.0 where some post types were flipped to be enabled (when they were set to be disabled). This was resolved a day later in v7.7.1. You can see the dates in the changelog which show this: https://wordpress.org/plugins/wordpress-seo/#developers

    This was most pronounced with attachment urls. An explanation can be seen here: https://yoast.com/media-attachment-urls/ regarding the issue.

    George

    (@quantum_leap)

    I don’t understand. V7.0 up to v7.7.1 is not one day later, its actually a few months later. Are you talking about v7.7.0 to v7.7.1?

    Plugin Support devnihil

    (@devnihil)

    We apologize, we meant from version 7.0 to 7.0.1, NOT version 7.7.1.

    George

    (@quantum_leap)

    But the issue was corrected from v7.7.1. Please see my first post and your changelog.

    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    @quantum_leap Right, the issue was fixed in Yoast SEO v7.7.1.

    George

    (@quantum_leap)

    Ok so basically ths bug(and I am not talking about the attachements bug):
    * Fixes a bug where disabling the post_format archive would result in it actually being enabled and vice versa.

    was introduced in 7.0. Version 7.0 was released March 6th, 2018. This bug was fixed on 7.7.1. Version 7.7.1 was released June 27th, 2018.

    That means that for 3 months and 21 days ALL years that had their post formats set to index on search engines would actually had those formats NOT indexing and possibly losing traffic. Is that statement correct?

    Please give me a CLEAR answer!

    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    While there was a bug and we fixed it already, there is not a good chance to lose traffic for this as a post with a format selected will still include in the post sitemap even when the post format sitemap is disabled.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.