WordPress.org

Forums

Post By Email
Post format (3 posts)

  1. Dominick Bosco
    Member
    Posted 1 year ago #

    This plugin is awesome! Thank you!

    I'm having just one issue, which is probably something I'm failing to do.

    Though I'm writing the email/post with paragraph returns, they are just not happenin' when the post is published! All one paragraph....

    What I do to fix it is go into the backend and change the post format from "format" to "paragraph." That does the trick--but needing to do that sort of defeats the purpose of the plugin. (Other than it's just so cool to use it!)

    Something I'm missing in my set up? (Catalyst theme w/Dynamik)

    Thanks!

    db
    BookBuxJungle.com

    http://wordpress.org/plugins/post-by-email/

  2. Kat Hagan
    Member
    Plugin Author

    Posted 1 year ago #

    Hmm. Those are weird post formats -- neither "format" nor "paragraph" is one of the built-in ones. Were those added by your theme?

    The current version of the plugin doesn't support custom post formats, but the development version does, which would circumvent this problem by allowing you to specify in the settings that it should use the "paragraph" format by default. That version will be released in a few weeks.

    In the meantime, it might be worth looking at your custom post formats and why posts are getting set to something called "format" by default. (Usually the post format gets set to "Standard", i.e., no special format.)

  3. Dominick Bosco
    Member
    Posted 1 year ago #

    Thanks for your reply.

    I went back and took a closer look. I sent a couple of test posts and examined what showed up in the post editor. (Ultimate TinyMce plugin is installed.)

    The post had four paragraphs.

    The first paragraph had the "Paragraph" formatting in the formatting style box in the editor. But the blank space below that and every line afterwards had "format" in the style box. The line spacing of the post on the front end was mixed up, too.

    I thought maybe it was the email formatting that was the issue. The first email had been sent as Rich Text.

    For the second test I changed the format to Plain Text.

    That solved the problem. In the post editor, all the lines of text and spaces between lines were "Paragraph" format. Line spacing was as I wrote it.

    In both cases, the auto post excerpt came out with no line spaces between paragraphs. That's not a huge issue for me.

    As I said, I'm using the Ultimate TinyMCE plugin for post and page editing. My theme is Catalyst-Dynamik.

    I'm looking forward to the next version. This is such a great plugin! Thank you!

    Dominick
    BookBuxJungle.com

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Post By Email
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic