Support » Theme: Hueman » Post Featured Image not showing in post view

  • Resolved John

    (@dsl225)


    Hello,

    Is there a particular setting for Featured Images in blog posts that I’m missing?

    Featured Images display in list view when selecting categories but when opening a given single post that has Featured Images.

    Thanks.

Viewing 15 replies - 1 through 15 (of 15 total)
  • Hi,

    You need to use image post format so that featured image display within single post.

    Thank you

    Thanks Denzel,

    What does this mean exactly?
    – If I have a featured image in my post, do I need to ADD the same picture in the post editor in order to have it display?

    Is this related to this particular theme or a general WP behaviour?

    I just tested with Customizr theme and featured images are showing up…

    do I need to ADD the same picture in the post editor in order to have it display?

    No.

    Is this related to this particular theme or a general WP behaviour?

    It’s based on the theme. Some themes show the featured image in the default “Standard” post format, others (including Hueman) only display the featured image if a particular post format is selected.

    In Hueman, if you want a large image displayed above the post content, you would add a Featured Image and, as @denzel mentioned, select the Image post format. If you want images within the post then you add them to the content.

    Ok got it!
    I didn’t understand what the Image Post Format was standing for at first.
    Thanks guys!

    You’re welcome.

    Wow, that had me stumped. I thought if Featured Images existed they would be shown, especially since they showed up on the blog page list. I’ve been trying to figure out why it was broken.

    I just converted from another theme. Is this saying that I now have to change every post to the “Image” format to get the Featured Image to display on the page?

    If so, is there another way? I thought about changing the single.php in a child theme, but after looking at Hueman’s code, that doesn’t look quite so simple.

    Any suggestions to minimize the amount of labor in converting a site?

    It’d be very helpful to know how to change all of my posts at once to “Image” format. It will be very time consuming to go into every one of my posts and make that change. Can you suggest a solution? Thanks.

    Yes, it’s a complete pain. I ended up making a child theme and modifying the code in a couple of files to fix it. It was a very simple change, but now I have to worry about keeping the child files in sync with the parent.

    I would say pester the theme author to make this theme like all (maybe only the vast majority) others: featured images show on the default post type. There could be an Appearance option to turn it off.

    I like the theme, but this was almost enough to make me start looking for another when I found the issue.

    Same situation for me. I’m also coming from using another theme and have thousands of articles already which used to show the Featured Image at the top of the article and using only standard post and now nothing with this one 🙁 I now read here that I would have to use “image Post” format *sigh* very very poor decision to make it this way ESPECIALLY for a MAGAZINE theme…go figure! 🙁 very disappointed with that aspect

    Please I have the same problem about showing image on main blog site with this plugin, I use Ipin theme wordpress. Please help me

    my website is jounalib.com

    I used the plugin – Bulk Convert Post Format – to change posts to type Image.

    Worked like a charm

    Cam

    @smythec

    I temporarily have done a similar thing to get the featured image to show. However I hope its just a temporary fix if I switch themes in the future I’m guessing it will cause problems to have all of my articles set as an “image” format. Also not sure if that has any effect on SEO stuff mis-categorizing my content as an image gallery when its actually an article?

    I hope the hueman theme author will modify the way this works or let us choose using a checkbox.

    I’m not sure if I’m wrong in thinking that pretty much everyone would want their featured image shown on a standard post, so I’m not sure why the theme author would have it set this way.

    • This reply was modified 2 years, 7 months ago by  daydull.

    Hallo,
    many months ago I had the same problem and I have made a note for myself that I have to add

    <br/>
    <?php if (has_post_thumbnail()) {the_post_thumbnail('full');} ?>

    into the single.php

    Now I updated the theme and I wanted to do the same again (at that time I didn’t knew what child themes are) but it doesn’t work. Do you know where I should put the code?

    • This reply was modified 2 years, 6 months ago by  jen-me.

    hello please i need your help….
    each time i try to post a link from my website on any social media network it will not show any image except an image like cartoon.
    my website link is http://www.caresphotos.com

    here is a sample link i posted on facebook and twitter
    http://www.caresphotos.com/talents/juliet-okechukwu/
    if you paste the link on facebook or twitter it will not show featured image

    i need help….its a modelling website

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Post Featured Image not showing in post view’ is closed to new replies.