WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Post error after updating

[Resolved] Post error after updating

  • Hello, I’ve updated today to WP3.5 and new Buddypress / Buddypress Media.

    Everything seemed ok front and back until i came to create a new post when i get this error…

    WordPress database error: [You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ” at line 1]
    SELECT post_id from wp_postmeta WHERE meta_key=’bp_media_child_activity’ AND meta_value=

    I uninstalled BP Media and the error has gone but i’d like it back as we want to really push it.

    Any help greatly appreciated.

    http://wordpress.org/extend/plugins/buddypress-media/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Rahul Bansal

    @rahul286

    @fpats

    Can you test with again with other plguins deactivated? Also, default buddypress theme?

    Just created a new post – http://demo.rtcamp.com/buddypress-media/test/ on demo site and did not find this issue.

    Plugin Contributor Saurabh Shukla

    @saurabhshukla

    Hi,

    Thanks for the pointer. We just noticed this. Strangely, this line is supposed to be called when an activity is deleted. We are a little baffled with why it is being called on adding a new post (and hence failing because it doesn’t get the right values).

    While we can quickly fix this, we’d like to dig a little deeper, especially since buddypress itself has been updated. This wouldn’t cause you much trouble except the annoying message. So, you can continue using buddypress media without worries.

    We are currently fixing this and some other minor issues. We will release an update soon (today, unless we uncover more issues, in which case, tomorrow). Kindly bear with us till then.

    Regards.

    Plugin Contributor Saurabh Shukla

    @saurabhshukla

    Hi @fpats,

    We realised that this is a bug in buddypress. We’ve raised a bug ticket on buddypress (currently in moderation).

    Instead of waiting for that to get fixed, we’ve improved our code so that even if called in the wrong context, it won’t throw unsightly errors.

    Closing this a resolved. Do confirm if it is working fine on your site.

    Regards.

    thanks for the replies, i’ve updated BP Media but still getting the error i’m afraid.

    I apologise, it didn’t update properly.
    I’ve just tried again and all is now fine.

    thanks alot!

    Plugin Contributor Saurabh Shukla

    @saurabhshukla

    Hi,

    You almost gave us a scare 😉

    Glad its working now.

    Regards.

    sorry! 🙂

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] Post error after updating’ is closed to new replies.