WordPress.org

Support

Support » How-To and Troubleshooting » Post Editor Toolbar missing

Post Editor Toolbar missing

  • My problem: My post editor toolbar is missing completely. I still have the “Upload/Insert” toolbar showing. I am able to type in a title for the post, but when I click on the body of the post, I am unable to do any typing.

    What I have tried (based on other threads I read on this topic): I have tried using two different browsers (Firefox and then Explorer) and the problem exists in each. I also tried resetting the cache in each one. I also looked at my personal settings and the “disable visual editor” bos is UNchecked.

    I use wordpress regularly but I am not the best with technical details or HTML code, so anything you can suggest in plain English that a newbie could understand is most appreciated.

    Thank you in advance for your help. I appreciate it.

Viewing 15 replies - 1 through 15 (of 18 total)
  • Have you recently changed themes or plugins at all? This could be a contributing factor…

    Moderator keesiemeijer

    @keesiemeijer

    Have you tried:
    – deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).
    – switching to the default theme to rule out any theme-specific problems?
    – re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress?

    I am having the issue, my visual view(kitchen sink) is gone.

    Have either @anniehaarmann or @otter1211 deactivated your plugins? Just select the plugins from the admin menu and de-activate them all. As @keesiemeijer suggests try again and if all is OK then activate your plugins one at a time until you find the one that causes the errors.

    As the plugins are loaded as the admin section loads (otherwise you couldn’t administer your plugins) a problem within the plugin could disable your admin panel by causing a script to fail.

    Unless you tell us what you have tried from our suggestions that have not worked we will find it very hard to help.

    I deactivated all of my plugins, logged out and logged back in again. My toolbar is still missing.

    I am going to try the other two suggestions next.

    Sorry to be a pest, but I have searched this concept in this forum and on Google and I can’t seem to find instructions on how to to it:

    re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress

    Does anyone know where I could find this info?

    Moderator keesiemeijer

    @keesiemeijer

    upload using your cPanel, or whatever file manager is provided by your host or use a ftp client to upload the folders.
    http://codex.wordpress.org/FTP_Clients

    Moderator keesiemeijer

    @keesiemeijer

    If all that doesn’t work try:

    Deleting or refreshing your browser cache. Try other browsers

    Visit http://yoursite.com/wp-includes/js/tinymce/wp-tinymce.php and look for any PHP errors or warnings at the top. If there are any try contacting your hosting provider to resolve them or try the next step. Of course replace yoursite.com with your domain

    Add define( ‘CONCATENATE_SCRIPTS’, false ); near the top of wp-config.php. That would make WordPress admin run slower, so can try removing it in a few days and testing again (this would eliminate any stale network cache)

    Thanks, keesiemeijer. It looks like this is going to be more complicated than I thought. I don’t have access to our ftp. I’m going to send this info to our hosting provider.

    Thanks again for trying to teach me how though. Now I at least know what to tell them to change.

    Make sure javascript is enabled in your browser’s settings.

    Experienced the same problem. My host said my loads of their customres had the same trouble and it might be a WordPress bug. All we can do is waiting for a bugfix. In case if you know any ideas to solve the problem pls let us know, would be thankful!:)

    Cheers!

    I’ve tried all of the above suggestions and my toolbar still doesn’t dipslay.

    There must be a bug somewhre!!

    Keczanm Its not a WordPress bug. If it was, a LOT more people on OTHER sites would have this problem. That your HOST says THEIR customers are reporting issues makes me think THEIR servers are screwed up.

    jmccann – Turn off ALL your plugins. Every last one.

    @ipstenu

    Every last plugin was switched off and it’s happening across a number of sites on different hosts servers. The common thing is they are all running WP 3.1 RC.

    Sometimes the toolbars will display, then if I do something like save the post or re-load the page they disappear.

    3.1 RC? We’re on 3.1.3 (or 3.2-RC1). If you’re really still on 3.1 RC, upgrade.

    Sometimes the toolbars will display, then if I do something like save the post or re-load the page they disappear.

    That’s a javascript error, then. So something’s overwriting it.

    1) MAKE SURE you’re on the latest version of WP. No one’s gonna waste time debugging an older version 😉

    2) If it’s STILL broken, try this:

    If you run into the problem where your toolbar disappears from your WYSIWYG editor as well as the WYSIWYG editor not working at all, try this.

    go to your wp-includes/js/tinymce/langs and create a symbolic link to wp-langs-en.js as en.js.

    ln -s wp-langes-en.js en.js

    Mind, that should be fixed as of 3.1.1

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Post Editor Toolbar missing’ is closed to new replies.
Skip to toolbar