Support » Plugins and Hacks » post editor stopped working after install

post editor stopped working after install

  • Hi, installed the plugin and was working great! Then I installed another plugin (Add from Server) and it forced the post editor to stop working. So in uninstalled that plugin and deleted it and deactivated the rest.
    One by one I reactivated them all until I got back to mb.miniAudioPlayer and when I reactivated it, the post editor stopped working again!
    So I deactivated, deleted and then re-installed it but the it now keeps breaking the post editor.
    I’m using WP V3.5, any suggestions? Would love to get it back working as I’ve done a ton of work already using it!



Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Author pupunzi


    This seams a problem of permissions. Instead of installing it from the plugin manager try to upload the mb.miniaudioplayer folder from your FTP in the plugin folder of the remote wordpress installation. This will preserve the permissions you had on your computer and probably solve your problem.


    Hi Pupunzi.. so I received permission from my admin to log in via FTP to install the plugin and this did not fix the problem. The Visual Editor does not work and is lacking a toolbar, including the map button that I want to use to customize my player for each post.

    Hi Pupunzi,
    Thanks for the reply, but I originally installed the plugin via ftp and no joy.

    Any other suggestions?

    Plugin Author pupunzi


    Can you tell me what is the error you get in the javascript console panel when you open the post editor page?

    I decided the easiest way to show you the error would be to provide a screen capture showing how the Visual Editor looks before plugin installation and after:


    As indicated in the screen capture, installing the plugin (either through the web-based admin Plugins page or through FTP), causes the Visual Editor to lose all of it’s buttons, text typed in the box is not visible, and switching between HTML to Visual Editor causes the HTML code to lose it’s formatting (all code appears on one line).

    We are using WordPress 3.4.1 but as indicated by alvC above, it’s also a problem on WordPress 3.5 (hopefully alvC can comment on the specific error he is experiencing, if it is not the same as us 3.4.1 users)

    I hope you can fix this, your plugin is probably the best for simply embedding MP3s that I’ve come across.

    Hi, I get the exact same situation in WP 3.5, the editor doesn’t completely load and no pages are editable.
    Unfortunately, I don’t have the javascript error console installed, I don’t know how to use it. But if you let us know the command lines to put in I can install and run it and I can post the error messages here.

    Btw – wrecknoble, in the meantime I installed Codeart – google mp3 player until the issue is resolved. But my first preference is Pupunzi’s audio player.

    Plugin Author pupunzi


    I experienced this same problem installing the plugin on a webserver and that was due to the permission restriction.
    the affected file is the tinymcemaplayer.js.php located in the maptinymce folder. As I need to pass parameters from the settings of the plugin to the plugin editor window, it must be a PHP page. What I think is that some service providers sets restrictions on calling server side files as javascript.

    Solving the problem is quite easy:

    1. Locate the file via your FTP client;

    2. select it and open the info box (I’m using Transmit where this action is available from the contextual menu on the file);

    3. locate where the permission settings are (here is a screenshot of the Transmit info box: https://dl.dropbox.com/u/1976976/wp_components/mb.miniaudioplayer/before.jpg )
    4. set all the “execute” permissions to true (here is the Trasmit screenshot: https://dl.dropbox.com/u/1976976/wp_components/mb.miniaudioplayer/after.jpg );

    5. Now the page has all the permissions and the problem should be fixed.

    If you can’t do that via the FTP client you can download the plugin locally on your computer, check the permission there and eventually set them correctly and upload the plugin via FTP.

    Unfortunately this is not a problem of coding and I can’t overwrite the server settings on permissions and on most installations that doesn’t happen; so this problem is fixable only by you.

    I’ll see if it is possible to pass those parameters somehow else and hope to find the way.

    Hope this can help you,

    Hey Matteo,

    I tried doing that via FlashFXP, you can right-click the file and choose Attributes to access the permissions. I changed all of the “execute” permissions to true and it still isn’t working, even after deactivating and activating the plugin.

    Not sure how else to go about fixing it. If you have any other ideas in the meantime, please let me know.


    FYI, updated to version 1.1 of the plugin and tried again to change the attributes to allow “execute” permissions on the file and still no luck.

    Plugin Author pupunzi


    You should controll what is the error you get opening the post editor page and send me the log.
    If you use Chrome you can access to the javascript consol via the main chrome menu on the right -> tools -> developer tools; once the window opens click on the “console” button and reload the page. There you’ll find the error description.

    Plugin Author pupunzi


    Plugin Author pupunzi


    Maybe the problem is elsewhere; can you control what is the error you get opening the post editor page and send me the log?
    If you use Chrome you can access to the javascript console via the main chrome menu on the right -> tools -> developer tools; once the window opens click on the “console” button and reload the page. There you’ll find the error description.

    Plugin Author pupunzi


    In the last 1.1.1 update you can disable the post editor custom settings button. That should make the post editor works and you can set the player using the general settings page.
    This is a work around to let you use the plugin.

    Thanks for the 1.1.1 update, disabling the custom settings button allows the post editor to work. Unfortunately I’m not at a computer with Chrome right now, but once I am back at my own laptop I’ll check to see if I can get the error from the javascript console.

    Finally got back to my apartment from my parent’s place and was able to use Chrome to check the error. This is what I am getting:

    Resource interpreted as Script but transferred with MIME type text/plain: "http://chrome.dealply.com/chrome_1357228151746/chrome_content.js?sg=&partner=dealplydef&channel=dealplydef".
    Resource interpreted as Script but transferred with MIME type text/html: "https://www.superfish.com/ws/sf_conduit.jsp?dlsource=fastestchrome&CTID=1_2012-11&userId=fastest00_fastestchrome_1_2012-11_". data:text/javascrip…:9
    GET http://itzsoweezee.com/wp-content/plugins/wp-miniaudioplayer/maptinymce/tin…YWJsZT0mZG93bmxvYWRhYmxlX3NlY3VyaXR5PSZkb25hdGU9dHJ1ZQ%3D%3D&ver=349-20805 500 (Internal Server Error) wp-tinymce.php:2
    Failed to load: http://itzsoweezee.com/wp-content/plugins/wp-miniaudioplayer/maptinymce/tin…40JmRvd25sb2FkYWJsZT0mZG93bmxvYWRhYmxlX3NlY3VyaXR5PSZkb25hdGU9dHJ1ZQ%3D%3D wp-tinymce.php:2
    Resource interpreted as Image but transferred with MIME type text/javascript: "http://ajax.googleapis.com/ajax/libs/jquery/1.7.1/jquery.min.js". sf_code.jsp:24

    I hope this helps you figure out what’s going wrong and we can get it resolved. The work-around you put in 1.1.1 is good for now, but I’d love to be able to have access to the custom settings button in the post editor.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘post editor stopped working after install’ is closed to new replies.