Support » Fixing WordPress » Post Editor missing in WP 3.5 after upgrade

  • Resolved brandonchicago


    I upgraded this morning and now my visual and text editors are blank boxes with no content. Disabled all plugins and changed the theme to Twenty Eleven, still no love. Tried in FF 17 and latest version of Chrome.

Viewing 15 replies - 16 through 30 (of 61 total)
  • Moderator Samuel Wood (Otto)

    (@otto42) Admin

    How to solve this sort of problem:

    First, clear your browser caches. You want to make sure that the browser is indeed downloading all the javascripts and such and not trying to use old versions.

    Second, if it’s still not working after a full clear and refresh, then check the Javascript console for errors. This will tell you what sort of problem you’re having.

    A 403 forbidden means that your browser isn’t able to load the scripts up because your server isn’t allowing it. Unfortunately, this is a hard one to solve. Anything could be blocking the server. Check your .htaccess files for anything strange, and/or ask your host what’s going on. Also try a full manual upgrade, to make sure all the WordPress files are there and correct.

    If you can actually load those links in your browser, then you should see all the code and that means that you should be fine.

    Any “not defined” messages mean that your browser is not loading all the scripts. Same basic problem, the trick is just to figure out why.


    That worked! Sounds like it’s not the best solution for the problem, but now I can use the admin again. 🙂

    I added this script to my wp-config.php file: define(‘SCRIPT_DEBUG’, true);

    Just to be clear, I had disabled all plugins and changed the theme back to Twenty Eleven and I was still getting the Jquery error, so I’m not sure if it was just a perfect storm of bad things happening or if there’s a bug in 3.5. Hopefully this helps others in the meantime who run into this problem.


    I agree it’s just a quick and dirty solution. But it will allow you to work on the site normally while the issue is fully resolved.

    It may be that something went wrong with the update of the jquery libraries on the latest update. Not sure what tho, I’m still going around and fixing problems before I debug anything. 🙂

    I think I found the cause.

    I’m using the BulletProof Security plugin, and even though I disabled the plugin, it leaves the .htaccess file full of “Bulletproofing”. When I changed the .htaccess file back to “Default Mode” and activated it, the JQuery error disappeared and the admin screen worked.

    Sounds like BulletProof Security is the issue.

    Good call!
    We must contact the developer ASAP, as I’m also using that plugin, not sure if this is the case for everyone.

    We leave the root .htaccess and wp-admin .htaccess files behind on plugin deletion to prevent catastrophic user error, but this needs to be stated more clearly/repeated in several places that are “in your face”. 😉

    I upgraded this morning and now my visual and text editors are blank boxes

    Can you give me exact details so that i can look at this and see what needs to be done/what needs to be allowed/etc. Thanks.

    At first glance it looks like load-scripts.php needs a skip/bypass rule created in the wp-admin htaccess file, but since i am not 100% sure of where the error is occurring/conditions when the error occurs then any details you can provide will narrow that area down.

    Thanks for showing up AITpro 🙂

    I knew we could count with you to help on this one. Is there any details I can give you to help you see if there is an issue?

    It’s a .htaccess problem.

    It is mostly happening on blogs with BulletProof Security plugin. Even if you deactive it, the “secure .htaccess” file it had created stays in place and fully operational.

    To FIX this issue (if you are using BPS) activate the plugin, go to the Security Modes tab, check the red “Default Mode WP Default htaccess File” radio button and click on Activate.

    I had to use revert to the default .htaccess in root and admin folders to get things working again.

    Yes, looks like BulletProof Security is the problem on my site. Excellent plugin. I’m sure there will be a fix soon enough.

    Amazing how many people are/were effected by this. All BPS users?

    @Xlllzen – the details i am looking for are does this problem occur generally. ie without involving another plugin or any other action on your part or does the error occur when trying to perform an action or is there a plugin involved in the process of the action that you are doing? Thanks.

    Moderator Samuel Wood (Otto)

    (@otto42) Admin

    The particular rule in question in your plugin that is causing the problem is this one:

    RewriteCond %{QUERY_STRING} ^.*(\[|\]|\(|\)|<|>).* [NC,OR]

    WordPress’s load-scripts.php URL can, as of 3.5, have square brackets in it, which this rule blocks.

    For example, this URL is valid:

    The load[] was changed from load because of a problem where the length of the load parameter could get too long for some webservers to handle properly. So now it’s split into a PHP array for handling this sort of thing.

    Removing that line from the .htaccess in the wp-admin will solve the problem.

    Thanks Otto – this damn rule has been nothing but a pain in the rear since day one. Consider it permanently modified ASAP in both the root and wp-admin .htaccess file. Square brackets are safe enough – I went too far by including them is this filter. I will release a BPS update ASAP that will preg_replace this damn pain in the neck rule.

    Thanks AITpro and Otto!

    It’s great to have such an active members like you around 🙂

    Thanks Otto!

Viewing 15 replies - 16 through 30 (of 61 total)
  • The topic ‘Post Editor missing in WP 3.5 after upgrade’ is closed to new replies.