Support » Fixing WordPress » Post editor blank for certain pages after restoring database

  • I am having a baffling problem that I can’t figure out.

    Last week, I discovered that if I restore a site database from backup (using UpdraftPlus), following the restore, certain pages appear to be blank in the Classic Editor window, both in the Visual and Text tabs, showing a word count of 0. (I do not use Gutenberg.) If I examine the posts table via phpMyAdmin, the HTML content is still there in the applicable post_content fields, and if I load an affected page on the front end, it appears to load okay. However, I lose the ability to edit it unless I recreate it from scratch.

    Not all content is affected in this way. For some reason, the effect appears to be limited to pages, not posts, and only certain pages. The pages affected appear to be consistent from incident to incident, but I can’t see any pattern in terms of size/length, age, or recency of update.

    Since the post_content appears to be being backed up and restored correctly (if I download and review the backup file, the posts table contains all the content as it should, and there are no significant errors in either the backup or restore logs), the problem doesn’t appear to be with UpdraftPlus. The plugin appears to be functioning as it should, and a test loading its database backup into a fresh WordPress database on the same server worked as it should.

    I HAVE previously been able to restore without issue, and had done so as recently as late October. This happens on multiple sites using different themes, so it’s not a theme issue. It occurs even if I disable all plugins other than UpdraftPlus prior to restoring.

    Doing some web searches suggests that a number of other people have had a similar issue, but found no solution that seems to help.

    I’m completely baffled. Does anyone have any thoughts? I’m running out of ideas. This is a big problem — I can’t restore from backup without rendering some of my most important page content (e.g., the privacy policy!) uneditable, and I can’t figure out why.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Does the problem appear in Gutenberg editor as well? (I know you said you don’t use it, but since Gutenberg is the DEFAULT editor now — unless you’re using an ancient version of WordPress — it doesn’t hurt to simply open one of the affected posts in Gutenberg just to test.)

    If the post appears in Gutenberg, you may want to post this issue in the Classic Editor’s own support forum (since this is now a plugin like any other plugin and separate from the WordPress core project).

    https://wordpress.org/support/plugin/classic-editor/

    Good luck!

    Thread Starter Ate Up With Motor

    (@ate-up-with-motor)

    I normally use the Disable Gutenberg plugin to get the Classic Editor, not the Classic Editor plugin.

    I tried disabling Disable Gutenberg, installing Classic Editor, backing up the database, and restoring again. It had the same effect I described.

    I very, very reluctantly disabled both Disable Gutenberg and Classic Editor and tried looking at one of the affected posts. This time, I was able to see it in the editing window in what I presume is the normal way for the Gutenberg editor. I didn’t poke at it much, since the misbegotten block editor has an extremely high risk of damaging the affected content further, in ways that are harder to fix.

    Something about restoring the database is causing certain post content to ONLY be editable through the block editor. I have no idea why, but that’s a nightmarish problem and I don’t know how to fix it.

    Good luck then.

    Thread Starter Ate Up With Motor

    (@ate-up-with-motor)

    I don’t know enough about how the editors work under the hood, so to speak, to analyze why this is happening.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Post editor blank for certain pages after restoring database’ is closed to new replies.