Support » Fixing WordPress » Post disappears in permalink

  • Hello. I’m using WP 2.0.4 and a modification of the Serinity theme. Things have been fine since I installed last August, but suddenly I get the following problem:

    My posts look fine when viewed in the index page, but if you click a permalink or go to comment (i.e., load a specific post), nothing appears except the banner and the background image.

    It’s not the template — I re-uploaded my template files to no success, and I switched to a WP default template and the problem was still there.

    If I look a the source for one of the blank pages, I see that the [head] info has loaded, but it seems to snag on the header as soon as it hits the link for the home page:

    [div id=”header” style=”height:150px; background-image:url(‘’); padding-top:5px;”]
    [h1][a href=”

    That’s where the source page quits. (I’ve changed angle brackets to [ and ])

    Here’s the blog:

    Go there and click on any post heading (or the comments link) and you’ll see what I mean.

    Anyone have any idea what’s causing this, or how to fix it?

    BTW, I’m terrible at database stuff, so be gentle with me!


Viewing 10 replies - 1 through 10 (of 10 total)
  • What happens if you switch to another theme? Like default or classic?

    Is there any conditional tag in that header portion of your theme?

    Moshu, I switched themes (or as I called them, templates) and the problem was still there. I’m not aware of any conditional tag in the header.

    Doesn’t seem to happen on the archive or category pages.

    Do you have a single.php file causing the problem? Perhaps an is_single() somewhere outside the header?

    You might try re-uploading the main WordPress files (the stuff in wp-includes) to the server, it’s possible that one of them got cut-off during the upload causing this to happen.. Seems unlikely, but hey, can’t hurt.

    Thanks Otto42. The thing is, it’s been months since I uploaded those files, and it’s been fine up until yesterday.

    I’ll try re-uploading anyway (not until tonight, as I’m away from my home computer) but I doubt that will make a difference.

    I’ve noticed that some of the permalinks work better than others. For the last couple of posts, all you get is the header and background. But for most of the older posts, you actually get the post content, but the container and all sidebar stuff is missing.

    I’m totally at a loss on this…

    I just noticed you stated you are using 2.04 Is there a reason why you have not upgraded to 2.05? You might want to do that first and perhaps your other issues will get resolved. At the very least 2.05 is an important upgrade to resolve some potential security issues. HTH!

    OK, I upgraded to 2.0.5. The problem is still there. 🙁

    I contacted my domain host, who reported the following database error:

    PHP Fatal error: Call to a member function
    get() on a non-object in
    <snip>blorkblog/wp-includes/cache.php on line 29

    This post in the support forms addresses this error:

    (change to cache.php because of problems with php5.2)

    But when I tried it, it just made the problem worse.

    Whoa! The problem has been SOLVED!

    It was nothing I did — apparently there IS A PROBLEM WITH WORDPRESS and PHP 5.2! This problem appeared when they upgraded me to PHP 5.2 earlier in the week (I only made the connection a few minutes ago). So my host downgraded me to PHP 4 and now the blog works just fine.

    The problem may be with one of the plugins. I had to disable hashcash for my pages and posts to work again.

    On a brand new installation of WordPress 2.1.2, I have also problem with the permalink. Strangely they do not all work…
    What does not work is any custom permalink which does not start by /index/ or /index.php/.
    So if I use /index/%category%/%postname% the permalink is working, I mean that when I click on an article, page, etc. I actually see it.
    If I use /%category%/%postname% the permalink is not working. On the front page, the link seems to be correct to a post (http://myserver/wp/category/article) however if I click on the link I get a 404 error.
    I have PHP 5.2.1 and I’m not planning on downgrading it, my path is to upgrade it always 😉
    So for the time being, I’m using the /index/ prefix for my permalinks, but before I put the site on production, I hope this issue will be fixed…

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Post disappears in permalink’ is closed to new replies.