WordPress.org

Ready to get started?Download WordPress

Forums

Jigoshop
[resolved] .post class destroys theme (23 posts)

  1. MRA_Andy
    Member
    Posted 6 months ago #

    Hello

    the latest 1.11.1 version affects my theme. Well it didn´t destroy completely but it had an nasty effect on the wrapping of my posts on the main site and cost me some time to fix it. The following line:

    .post { padding: 15px !important }

    should better be

    #shop.post { padding 15px }

    so sites with no shop-content won´t be affected.

    Thanks

    https://wordpress.org/plugins/jigoshop/

  2. Breinbrouwsels
    Member
    Posted 6 months ago #

    Effect my picochic theme also by placing the excerpt now under the productimage

    This starte with 1.11

  3. MRA_Andy
    Member
    Posted 6 months ago #

    The problem still exists in 1.11.2
    It´s a bit annoying as you don´t really need that !important there. Please find a solution that does not effect the wrapping of the posts on the main page of a blog.

  4. Jigoshop Support - Marcin
    Member
    Plugin Author

    Posted 6 months ago #

    Thanks for letting us know - it will be fixed in next update.

  5. MRA_Andy
    Member
    Posted 6 months ago #

    that would be good :-)
    thanks Marcin

  6. Breinbrouwsels
    Member
    Posted 6 months ago #

    I'm not sure if my problem is the same as the one from MRA_Andy but is it still there. Please look after the link I gave you a week ago. Price, button,. excerpt are now somewere under the productpicture.

  7. Dusan Blaho
    Member
    Posted 6 months ago #

    I am experiencing the same issue in the last two versions of Jigoshop.
    The product summary, price and add to cart button are not next to product picture as they used to be and they are somewhat missaligned, sometimes under the picture, sometimes in the middle of the product page...
    Examples here:
    http://www.cajovnazarohom.sk/e-shop/amalaki-plod-sladeny-50g/
    http://www.cajovnazarohom.sk/e-shop/caj-na-laktaciu-100g/
    http://www.cajovnazarohom.sk/e-shop/baza-cierna-kvet-50g/
    I wonder if this is something that is going to be fixed sometime in the future or if i should start looking into some temporary fix.
    Thank you for your answers.

  8. Breinbrouwsels
    Member
    Posted 6 months ago #

    Same with me. It started with the version where the modification for the Woo Themes was made.

  9. Jigoshop Support - Marcin
    Member
    Plugin Author

    Posted 6 months ago #

    It seems to be same issue but please let us know if it's not solved after update to 1.11.3

  10. Breinbrouwsels
    Member
    Posted 6 months ago #

    OK, thanks, I'll let you know.

  11. Dusan Blaho
    Member
    Posted 6 months ago #

    Will do Marcin.
    Thanks for now and keep up the good work

  12. Jigoshop Support - Amadeusz
    Member
    Plugin Author

    Posted 6 months ago #

    Just to be sure issue is fixed - someone can add ".jigoshop" before ".post" in jigoshop/assets/css/frontend.css file on line 181? This way problematic definition will work only on Jigoshop pages.

  13. Breinbrouwsels
    Member
    Posted 6 months ago #

    Do I understand this well?

    " .jigoshop .post { padding: 15px !important }" ?

  14. Breinbrouwsels
    Member
    Posted 6 months ago #

    I tried a lot but no effect at all. And some are different:
    Under to the middle

    Seems OK

    Under picture

    Looks like it is lined out to the right

  15. Jigoshop Support - Marcin
    Member
    Plugin Author

    Posted 6 months ago #

    @breinbrouwsels can you provide us your site access via support@jigoshop.com? we'll take a look if there is anything else that could cause the issue.
    To confirm - these things worked fine before 1.11?

  16. Breinbrouwsels
    Member
    Posted 6 months ago #

    Yes, evrything worked fine before 1.11 where a modification for the Woothemes was made.

    I have 30 other sites working perfect on 1.10.6. If I update the problems starts. I tried this several times and had to uninstall this update and install 1.10.6 instead. I have made no changes, installing plugins or whatever.

    Sorry, I am not familiar with giving site access to third parties.

  17. Jigoshop Support - Marcin
    Member
    Plugin Author

    Posted 6 months ago #

    and can you send us the theme?
    not sure where to get it from to test it out

  18. Breinbrouwsels
    Member
    Posted 6 months ago #

    WordPress theme is Picochic

  19. Breinbrouwsels
    Member
    Posted 6 months ago #

    I activate 2014 theme for a couple of hours.
    Same problem.

  20. Jigoshop Support - Marcin
    Member
    Plugin Author

    Posted 6 months ago #

    thanks for your feedback, checking it out

  21. MRA_Andy
    Member
    Posted 6 months ago #

    I just updated my page and can confirm that the problem is solved with 1.11.3.
    Thanks

  22. Jigoshop Support - Paul
    Jigoshop Support Rep
    Plugin Author

    Posted 6 months ago #

    Hi MRA_Andy,

    Thank you for your feedback and confirmation that it's sorted in the latest version of Jigoshop.

  23. Breinbrouwsels
    Member
    Posted 6 months ago #

    Thank you all it's a beauty!

Reply

You must log in to post.

About this Plugin

About this Topic

Tags