Support » Plugin: Gutenberg Blocks Library & Toolkit - Editor Plus by Extendify » Post category metabox not displaying checkbox selections

  • Resolved mktwain124

    (@mktwain124)


    Thanks for all your hard work! Unfortunately, your plugin is somehow prohibiting the checkbox selections of the categories metabox on all my posts so I can’t use it right now. On posts, it does update the database correctly and I can verify it via the Quick Edit (which shows the correct categories assigned to that post). Yet the categories metabox on the post edit page won’t show any of the categories selected when I go to edit the post.

    I have deactivated all the plugins and only activated yours to see if there is a plugin conflict and get the result described above. It functions correctly when I deactivate your plugin. I have the latest versions of all the plugins including yours and WP core. Any suggestions?

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Munir Kamal

    (@munirkamal)

    Hi @mktwain124

    Are you sure this is due to the Editor Plus plugin? I just ran a test on a new test website using the Tweenty Tweenty theme and no other plugin installed. Seems to work fine?

    📺 https://share.getcloudapp.com/nOunyWDg

    What theme are you using?

    Thread Starter mktwain124

    (@mktwain124)

    Hi Munir
    Thanks for checking and for the quick response. I don’t know what else it could be since I just deactivated all the plugins except for Editor Plus again and then changed the theme to Twenty Twenty – and got the same result of the category metabox not working right. I tried it on both my local development site as well as my remote server. I also created a new site on my remote server with just WP installation, installed/activated Editor Plus as the only plugin, the theme was already set to Twenty Twenty and got the same result, the category metabox isn’t showing that post’s selection(s).

    Remember, if I change the category selection while editing the post, it does make that change correctly to the database and shows up in Quick Edit. It just doesn’t show any category selections in the category metabox when I use the main post editor. Since my site is primarily a blog, it is mostly posts and if the category metabox doesn’t show my current selections, I probably can’t use your plugin.

    BTW, I am using Mai Delight that is part Genesis framework.

    ulicgn

    (@ulicgn)

    Hello Munir,

    I can confirm this problem. If Editorplus is active, all the category metaboxes are empty when the post is opened in the editor (right column, under “categories”) As soon as Editorplus is disabled, the ticks show up correctly.

    If the post is edited and saved, the category it was assigned remains intact even though the boxes are not ticked. If changing categories by ticking boxes, these changes are saved, too. However when opening the post in the editor next time, the ticks are gone. So it seems to be a display problem.

    BTW – I activated 3 different themes (Neve, my Child Theme of Neve, and Twentytwenty).
    The problem persisted in each of them. Even if Editorplus is the only plugin active.

    Regards
    Uli

    PS: The video you posted was missing the important part. You had empty checkboxes and then you saved the post with some categories ticked. But you did not reopen the post in the editor and looked at the checkboxes. In my case, the checkboxes are empty every time a post is opened in the editor.

    • This reply was modified 3 months ago by ulicgn.
    Plugin Author Munir Kamal

    (@munirkamal)

    HI @ulicgn @mktwain124

    Can you test this along with Gutenberg plugin active please?
    https://wordpress.org/plugins/gutenberg/

    Let me know if this works fine with that or not?

    Regards,
    Munir

    ulicgn

    (@ulicgn)

    Hi Munir,

    I did some tests on two different WP sites. Installing the Gutenberg plugin did not change the behaviour. Again, I activated different themes: Twenty-Twenty, then an ancient theme I created 7 years ago, and finally the brand-new Neve theme.
    Also, I activated and deactivated different plugin combinations. Whenever Pluseditor is active, the category checkboxes are unchecked when a post is opened in editor, even if Editorplus is the only plugin that is active (plus the Gutenberg plugin).

    Also, I tried both the fullscreen- and the regular editor setting, in both settings the checkboxes are empty.

    Regards
    Uli

    Plugin Support mohammedeisa

    (@mohammedeisa)

    Hi,

    I just tested the categories metabox while Editor Plus is active and couldn’t replicate your issue.

    Can you please let me know if the issue still happening on your end?

    Hi,

    even with the newest update of EditorPlus, the category tick boxes are empty when I open a post for editing. If I tick one or more categories and hit the Save/Update button, the category ticks are empty afterwards while I am still in the editor ( however the category assignment is saved ) .
    This was tested with all components (WP, Editorplus, Neve Theme ) being on the newest version. I even tested with the latest Gutenberg Plugin both active and inactive.

    When Editor Plus is disabled, the category ticks remain intact.

    Regards,
    Ulrich

    • This reply was modified 1 month, 2 weeks ago by ulicgn.
    Plugin Support mohammedeisa

    (@mohammedeisa)

    Hi,

    Please open the browser console, replicate the issue, and share any errors you will find with me. This article will guide you on how to open the browser console: https://support.airtable.com/hc/en-us/articles/232313848-How-to-open-the-developer-console.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.