WordPress.org

Forums

[resolved] Post categories - not shown from dashboard (21 posts)

  1. Jerham
    Member
    Posted 1 year ago #

    I am having a challenge being able to locate some of my post categories from the dashboard and therefore I am unable to select these categories whenever I am creatin new posts.

    Also from teh dashboard they are not shwoing up in the list of categories. I know they are there because I am able to locate them when I type the names in category search.

    Can someone explain why these categories would be hidden on teh dashboard?

    I am using a multisite and only one of the sites is having this problem and all the sites share the same plugins.

  2. Are those post categories ADDED to the subsite? They're not shared, after all.

  3. Jerham
    Member
    Posted 1 year ago #

    The sites have their own post categories. I have two sites. Only one of the site is displaying this problem.

    Some of the categories are hidden from the dashboard and so I cant add new posts to these categories. They do not show up in category list nor the post selection option for new post.

    I deleted these post categories and recreate them thinking that would resolve the problem. The new post categories appear but a few of the older ones then subsequently disappear.

    The only time I am able to locate these hidden categories is when I look for them in post search.

    I was also having some server error issues I am not sure if that could be teh cause. I called my host company and they said the server problem is with the .htaccess file.

  4. Some of the categories are hidden from the dashboard

    I don't know what you mean by 'hidden' on the dashboard. Where do you see categories on the dashboard? I see them on the category page OR on the post edit page.

  5. Jerham
    Member
    Posted 1 year ago #

    Post categories and post edit - I am unable to select some of the category options that were created.

  6. Are you logged in as a site admin?

  7. Jerham
    Member
    Posted 1 year ago #

    Yes I am site admin and logged in

  8. Is there anything 'different' about the site? Different theme? Different plugin config?

    I can't reproduce this on any site on Multisite.

  9. Jerham
    Member
    Posted 1 year ago #

    Same plugins for both sites, same theme. One site in Spanish the other in English. post categories and post edit works fine on spanish site. I was told by serever host that the server errors is due to the .htaccesfile. Not sure what the problem could be.

  10. What's in your .htaccess then?

  11. Jerham
    Member
    Posted 1 year ago #

    In order to do the multisite setup there was a code that I had to copy from Network Setup to the .htacces file. The multisite worked perfectly. Then recently I started having these server errors and I called the server company they told me there is a problem with the code in htaccess.

    I once a again go to the wordpress code and realise that it was now slightly different from the one I had originally placed in the htaccess file.

    The original code begins RewriteRule ^index\.php$ - [L]

    The new code begins

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    So I copied the new code that I saw in my wordpress and add replace it with what was in the .htaccess file. But the issue still persist.

    This is my 1st attempt to build my own site. I was doing very well until I encounter this.

  12. No, not copy, replace. You were supposed to replace the old code.

    What is your full and complete .htaccess, please? And use the code tags (see the buttons above the text box?) to wrap the code in please.

  13. Jerham
    Member
    Posted 1 year ago #

    Thats what I did, I replaced it with this code.

  14. Jerham
    Member
    Posted 1 year ago #

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
  15. And that's the entire .htaccess? You don't have anything else?

    Are you using subfolder sites on your network or subdomains?

  16. Jerham
    Member
    Posted 1 year ago #

    I am using subfolder. Thats the entire code.

  17. The only time I am able to locate these hidden categories is when I look for them in post search.

    Which 'search' are you using? What page are you on?

  18. Jerham
    Member
    Posted 1 year ago #

    there is a search box on the page which displays the list of post categories. I am able to locate the hidden categories when I do a direct search and that's how I know they have not been deleted

  19. That sounds like you have a bug in your DB. Try running a repair on it.

  20. Jerham
    Member
    Posted 1 year ago #

    Ok thank you. I will get that done and let you know the results

  21. Jerham
    Member
    Posted 11 months ago #

    customs post order plugin was the source of the problem. Matter resolved

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags