Support » Fixing WordPress » Post captioning of images throws off their alignment

  • If you insert an image WITHOUT caption and align to the left or the right of the text, no problem.

    If you insert an image WITH caption and align to the left or the right of the text, no problem either.

    However if you try to add a caption LATER ON to an image you aligned and inserted in the text originally WITHOUT caption, the image is thrown to the bottom of the paragraph you tried to align it with.

    So it seems that there is a problem with POST CAPTIONNING of images in WordPress 3.9

Viewing 15 replies - 1 through 15 (of 19 total)
  • esmi

    (@esmi)

    Forum Moderator

    Can you replicate the problem using the default Twenty Fourteen theme with all plugins deactivated?

    Yes, same problem with default Twenty Fourteen theme with all plugins deactivated

    I also may add that I’ve tested this issue on 2 different servers, with 2 completely different web sites, running different non default themes. It just happened after we upgraded both to WP 3.9

    esmi

    (@esmi)

    Forum Moderator

    Can we see a page demonstrating the problem when the site is using the default Twenty Fourteen theme with all plugins deactivated?

    Our sites are live and I cant really leave the default Twenty Fourteen theme up for more that a couple minutes for testing, however it looks exactly like this:

    http://myarlingtontx.com/test/

    esmi

    (@esmi)

    Forum Moderator

    I’m sorry but there is no magic bullet in these situations. This is just the start of basic troubleshooting – a process of elimination deliberately designed to locate the root cause as quickly as possible by first removing the most obvious and common culprits via a series of (often) temporary steps.

    Your theme & plugin settings are saved in your database and should be retained for future use.

    Ok, check it out now http://myarlingtontx.com/test/

    esmi

    (@esmi)

    Forum Moderator

    The second image on that page has been added after all of the text, so I can’t see any issue. Can you try adding it in the middle of the text?

    Actually it has been added right before the letter B of BLOCK 2 but since we went back and added a caption, the system pushed it at the bottom of the paragrah.

    POST captioning the image is the problem.

    esmi

    (@esmi)

    Forum Moderator

    POST captioning the image is the problem.

    I’m aware of that, thanks. I’ve have tried to replicate your problem using the same set of steps but thus far, I can’t. The alignment/text wrap continues to work just fine for me with no “pushing down” of the image.

    How exactly are you captioning the image after it has been inserted?

    I click on the little pen icon on the image to get to IMAGE DETAILS, then type in the caption field and then UPDATE button.

    One thing both sites have in common is the fact that they have the latest JetPack installed… could this is be the origin of the issue?

    Sorry, I had to revert the theme back to the our regular one and turn our plugins back on.

    esmi

    (@esmi)

    Forum Moderator

    I click on the little pen icon on the image to get to IMAGE DETAILS, then type in the caption field and then UPDATE button.

    I’ve just done exactly that on a pre-inserted, previously uncaptioned & right aligned image and I still cannot replicate your problem.

    One thing both sites have in common is the fact that they have the latest JetPack installed… could this is be the origin of the issue?

    I wouldn’t have thought so but you could try deactivating Jetpack and see if it helps. Are you using the Photon module in the plugin, by any chance?

    Ok, so I’m testing on a third site WITHOUT JetPack, running no plugins, and on the default Twenty Fourteen theme. And I’m getting the same exact problem :\

    http://myarlingtontx.com/MYC/115-2/

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Post captioning of images throws off their alignment’ is closed to new replies.