Support » Plugin: Jetpack by WordPress.com » Post by email seems to have a problem with pic size

  • I just installed Jetpack 2.0 today and I’ve got the email a post feature working, but it posts pictures using the large size vs. the default media size, and I can’t find a way to override it. I can’t use is because all my other pictures are a different (default) size.

    http://wordpress.org/extend/plugins/jetpack/

Viewing 15 replies - 1 through 15 (of 27 total)
  • I came to post a similar question so I’ll add it here.

    First, I was very pleased to see how nicely post by email has come along. The last time I tried it, image attachments weren’t even allowed! The Postie plugin seems to have stopped working so I was looking for an alternative.

    Anyway, it worked just fine. But the picture that was posted was huge! When delivered by email it even gets cut off in size.

    Is there a way of limiting the width and scaling down proportionately, like you can choose 600×600 with the WordPress app?

    Thanks,

    doug

    Hi there, i also have problems with the attachment photos on the email, with one the size is too big, and is not possible to control it, if there are more than one, the gallery doesn’t work fine (probably because i’m using lightbox)
    I’ve been trying to find the code where jetpack creates the post, but no luck, if someone knows about, i’ll be greatful.

    Thanks!

    Yep, just tried to give it a go and had the same problem, is this a known bug or am I doing something wrong?

    Would be great to get this sorted as I can see myself using this feature a lot.

    Lubyg

    (@paontheweb)

    Same here. Single images are too large no matter what you do. We always install Resize at Upload or Plus which is great for logged in users who don’t know how to resize images. The email thing works great with the one exception of a single image. I’ve tried everything. If they get this fixed it will be the best group of features I’ve ever seen.

    More than one image works great so yes, it is probably your Lightbox Plugin mrmini. Try using the Jetpack Carousel.

    Lubyg

    (@paontheweb)

    Hey All, I just activated Photon and the email image size issue is resolved on my site. Check it out. Just go to Jetpack and Activate Photon then email in a larger image.

    Lubyg

    (@paontheweb)

    You may also need to make sure your Media setting are adjusted. The image does not seem to match what is set in the Media settings but at least it is not blowing out the page.

    Checked on WP MU and Single WP installs. Latest everything.

    Hey All, I just activated Photon and the email image size issue is resolved on my site. Check it out. Just go to Jetpack and Activate Photon then email in a larger image.

    With Photon, doesn’t that mean all your images are stored at wordpress.com instead of in your local media?

    I would worry that that reduces the portability of my site. Not a real worry?

    Thanks,

    doug

    paontheweb, thanks for your reply, but still not working, i’m going to look for another plugging to post by email!

    Thanks!

    +1, same problems here. Why is post by email still such a problem anyways? I am also one of those who have switched from Postie to Jetpack for that email thing. Wish I could present an answer, but this also looks like a bug to me on Jetpack’s side (of how incoming email is handled).

    Plugin Contributor designsimply

    (@designsimply)

    With Photon, doesn’t that mean all your images are stored at wordpress.com instead of in your local media?

    No. Photon caches the images and makes them faster. Your images are still stored on your site and If you turn off Photon, it will just go back to using those instead. Super simple.

    I would worry that that reduces the portability of my site. Not a real worry?

    Nope, you shouldn’t worry about that at all.

    +1, same problems here. Why is post by email still such a problem anyways?

    Post by Email is actually not an easy feat. As a matter of fact, the implementation by WordPress.com is pretty awesome. Bugs happen too, and we are around to work on them and fix them when they do. Posting relevant information and details about whatever issue you’ve run into is really the only way to help with that process.

    Regarding the image sizes, I’m not sure what’s happening yet, but I will look into it and report back here as soon as I have more information.

    Designsimply,

    So using Photon is not expected to help with this picture size issue?

    By the by, I had been using Postie, but recently it seems to have stopped working for some reason and so I deactivated it and was trying this.

    Thanks,

    doug

    Plugin Contributor designsimply

    (@designsimply)

    So using Photon is not expected to help with this picture size issue?

    I don’t think the image size issue reported earlier in this thread is related to photon at all. Photon just takes an image at whatever size and caches it so it will be served faster. It doesn’t adjust the size of an image that was inserted too big (like the Post By Email issue described above). Hopefully I’m explaining it clearly enough. 🙂 Let me know if you still have any questions about it.

    No, no questions. Thanks. I’ll just continue to use the wordpress app on my iPhone until the image issue is resolved.

    Thanks!

    doug

    mrmini

    (@mrmini)

    Hi there, i’m still looking for a solution, i have found “[attach …]” in the data base, so i imagine that when jetpack solve this shortcode is when do the mistake. I have found something in …jetpack/…/themes/…/minileven/image.php but not sure if this is the place, actually is not working this change

    any sugestions could be great, thanks

    downsouth

    (@downsouth)

    No fix on this yet? I can live with it posting either as a thumbnail or as medium, but “full size” is useless. This shouldn’t be happening – it feels like a web problem from 1995.

Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘Post by email seems to have a problem with pic size’ is closed to new replies.