Support » Plugin: Jetpack by » Post By Email disappear without trace

  • Resolved Adrian


    I’m building a site for a client and have set up an editor user which I will pass over to them when it goes live.
    Currently the test site is sitting in a subdirectory of the current (non WordPress) live site.
    When the new site is ready to go live I’ll reconfigure so it looks as though it’s in the root directory.

    The home page is currently
    but it will go live at

    I’ve set up Jetpack stats (which appear to be working).
    Now I’m trying to get Post by Email working for the new user which I connected to
    Emails to the generated post-by-email address seem to go down a black hole.
    I looked at the user’s profile on
    The address of the user’s WordPress site is listed as
    I haven’t found a way to correct that to what it should be currently, i.e.

    Could this be the problem?
    How can I fix it?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Contributor Richard Archambault



    Jetpack seems to have been connected with a development URL ( ; site ID 63744307). I’ve fixed it to be instead on our end, but you’ll have to disconnect and reconnect it for it to work for Post by Email.

    When you’re ready to move the site over to the live site, you need to disconnect Jetpack before migrating the db or changing the site’s URL, and then connect it again once the new site is live in the root domain. Once you’ve done that, you’ll need to generate a new secret email address for Post by Email, and the site will have a new Site ID on our end (since the URL will have changed). This means that the stats for the development site won’t appear, but since it’s a dev site, I doubt that matters.

    Does that clarify things for you?

    Thanks for looking into this.

    I followed the steps you recommend.
    When I try to reauthorise Jetpack, the following error message is displayed:

    502 Bad Gateway
    The server returned an invalid or incomplete response.

    If I revisit the Dashboard of my site, it appears as though the reauthorisation has worked. The site is correctly listed under My Blogs at with the URL

    However if I hover over the “Manage” link, the URL displayed is
    and when I click on it I don’t get the Manage page.
    I tried pasting that URL into the address bar of the browser with 0, 1 or 2 trailing slashes but all I get is the blue top navbar followed by
    “Unable to load manage page for this blog.”

    Post by email still doesn’t work.

    I have another dev site at (with WordPress installed in the root folder) where I also cannot get post by email working.
    Does it matter which email client I use?
    Does the email have to originate from the registered email address?
    Or is the only requirement to send the email to the generated private email address?

    You mentioned my site ID 63744307.
    Should I be able to discover my own site id?
    Is it important to know?

    Everything else about WordPress works so well I am finding it frustrating not to be able to use Jetpack post by email or figure out how to go about debugging the process.

    Plugin Contributor Richard Archambault



    Do you still get that message (502 bad gateway)? Because on our end, the site appears to be properly connected:

    So PBE should function. It looks to me that you reconnected 7 hours ago. Can you try regenerating the secret email, and then trying again to send it? It shouldn’t matter what email client you’re using, but it’s possible that the emails are getting caught by our spam filter. Can you specify what the subject linein your tests?

    As for the site ID, I wrote it more as a note for myself, but you canfind it if you view your site’s source while not logged in, near the bottom; it’s part of our stats code.

    As for, that site also appears to be connected correctly:

    Could you try regenerating the secret email address and write in to it again as well?

    I decided to try to continue this thread using the Jetpack support form.
    In summary, the situation is that I do still get the 502 errors.
    Both the sites I tested, where post by email doesn’t work, are hosted by the same service provider.
    I maintain another WordPress website on a different service provider, where Post By Email works perfectly.
    What could be the problem?
    Is the level of PHP relevant?
    (they are different)

    Plugin Contributor Brandon Kraft


    Happiness Engineer


    I’ll take care of your thread in our support system and will respond there shortly. I’m marking this thread as resolved since we’ll use the new one to continue.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Post By Email disappear without trace’ is closed to new replies.