Support » Fixing WordPress » post blank – max size issue?

  • waitman

    (@waitman)


    Hi,

    When I post something preformatted in HTML that’s over 100K or so (between 100K and 170K) the post is blank. Editing the post – the edit texarea is blank. The title shows up on the main index page without and text, clicking on the title takes me to the full view page but it’s blank.

    In the database table, the full text is there. In phpMyAdmin I can view all the rows of the entries and hit the full text view, it shows a big long page with several posts that are over 100K each. But they are blank in WordPress.

    There are no errors or warnings in my logs.

    My php.ini is set, I upped the max memory limits and timeouts.

    Still blank on the site and blank in the “edit” but it’s all in the database.

    Any ideas? This doesn’t seem like a php or mysql or memory issue. (because i can view several posts in phpMyAdmin without any problem).

    I grepped for “strlen” and “max” and “limit” and “set_timeout” in all the WP files and didn’t see anything useful. I’m wondering if this is somehow a utf8_conversion (or another similar conversion) problem. I seem to remember php mysteriously returning blank strings from the utf8 conversion function when working with large xml files. I had to break the data up into chunks to get it to work. That’s my memory anyhow, I’ll check it out.

    other than that, any ideas or feedback? I appreciate your help.

Viewing 6 replies - 16 through 21 (of 21 total)
  • Have this problem too. I dont have enough rights to test or use the solution with changing that php.ini parameter. Commenting the string out works but all the formatting losts… Changing the line, like azaozz described in trac didnt helped.
    Thanks to all of you (escpecially to waitman, duncanmc, azaozz) for your hard trying to solve the problem.

    I am having exactly the same problem. I have finished my first long post since my last WordPress upgrade and it turns out blank. I have a lot of photos in the post and when I add more than a certain number of them the resulting post is completely blank.

    I tried commenting out

    “$pee = preg_replace(‘/\n?(.+?)(?:\n\s*\n|\z)/s’,
    “$1\n”, $pee);
    // make paragraphs, including one at the end”

    (formatting.php line 71)

    and my post came back and displayed all the photos. Unfortunately all paragraph breaks for my entire blog disappeared. Obviously this is not acceptable. Does anyone have the answer. I am completely stuck.

    Please and thank you ahead of time.

    I solved my problem by changing my PHP version from 5.2 back to 4.4. I had recently upgraded to 5.2 to use a new plugin I wanted.

    Note: The plugin was not the problem. I had uninstalled it before this problem of the long post causing blankness came up.

    I was having the same problem. I created a quick post and it appeared on the main page. After analyzing the various posts, I noticed that the post that appear on the main page had no categories selected. I reposted the information without the categories and it worked.

    I would like to start using categories again. Has anyone experience the same issue?

    I had this problem. The only “fix” that worked was increasing pcre.backtrack_limit as duncanmc suggested. No more php4 cgi for me!

    The fix mentioned above worked for me, with an apparently-empty long post on my blog.

    < ;pcre.backtrack_limit=100000
    ---
    > pcre.backtrack_limit=1000000

    Morgan

Viewing 6 replies - 16 through 21 (of 21 total)
  • The topic ‘post blank – max size issue?’ is closed to new replies.