WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Post Archive links render "Not Found" after moving blogs

[Resolved] Post Archive links render "Not Found" after moving blogs

  • Greetings, I moved two blogs from an old site to a new site and server. To move them, I installed Word Press into two sub-directories on the new site, then did .xml exports from the old blogs which I imported to the new (I did not export directly from the data base and I did not use PHP MyAdmin). These blogs now reside at: http://kalarhythms.org/usa/blog/ and http://kalarhythms.org/megarhythms/blog/

    Now, in the right hand column under the “Post Archive” header, links to posts from previous months do not work. Instead they produce a page with the message “Not Found.”

    The links on the right side under “Post Archive” worked on the old blogs when they were on the old site. Neither of two new blogs has an .htaccess file.

    What can I do to restore function to the new blogs so that links to the Post Archive will work? Thank you.

Viewing 15 replies - 1 through 15 (of 19 total)
  • Go into your permalinks settings and resave them.

    Also, did you copy your .htaccess over?

    Hi ipstenu, thanks for the response. After reading your reply I went to my Permalinks and did a “Save Changes” (even though I didn’t make any changes). I did not copy my .htaccess over from the previous site and I cannot retrieve it. However, I did try uploading various versions of .htaccess files that I found recommended for use on the web. None of them worked. Any ideas?
    Thank you.

    At the bottom of the permalinks page should be a note saying either it rewrote your .htaccess or what to put in the file. Is that there for you?

    if nothing else works, create an empty .htaccess file, then go to your permalinks, hit save again, and this maybe adds the needed lines to your htaccess file
    if not, do what ipstenu said: check the bottpm of the permalinks page and copy it from there

    Hi ipstenu & seven26, I did another “Save Changes” on my Permalinks but it did not create an .htaccess file. So, I created and empty .htaccess file and Saved my Permalinks again, but the file is still blank. I never got a message on the bottom of the Permalinks links of any kind, only a message at the top of the page that said “Permalink stru cture updated.” What can I try next?

    OK, doing a Save of my Permalinks Did create an .htaccess file when I clicked to change the Permalink setting from “Default” to “Month and name.” However, now that the .htaccess file is there the Post Archive links are still not working, they still produce a “Not Found” message.

    with your ftp ulploader select the .htaccess file, change the attributes to 755, go and save permalinks again. If it works you are fine, if not set it to 777 and save, check. If it works put back the .htaccess attributes to 755

    it that don’t work, let me know what type of permalinks you want to use and I copy a code that should work

    Wow! OK, I tried changing permissions and the Post Archive links still do not work (also, when I do a W3C Link Validation from http://validator.w3.org/ it show many Permalink errors). The type of Permalinks I would like are “Month and name.” If this works it will be fantastic! I have many blogs that I have moved with this same problem.
    Super big Thank You for your efforts on this!

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    for Month and name

    hmm I never checked, but for a first glance this look exactly the same in any cases

    I do appreciate the effort, but when I tried this new .htaccess file that you kindly wrote the blog became unviewable with an “Error 500 – Internal server error.” I changed permissions of the .htaccess file to 777 but the results were the same.

    🙁 that is very strange. if you empty the htaccess file, it should go back to normal. Don’t forget to save the permalinks to the default ones.

    but I suggest you to keep trying, because at a split second, the first blog worked with the permalinks you wanted. I opened one of your posts and it didn’t gave me the error

    so what I would try again:
    delete the .htaccess
    create an empty one
    set permission to 777
    save permalinks
    refresh the page, check permalinks

    if works set .htaccess to 755

    I have the .htaccess file you wrote in the first blog ( http://kalarhythms.org/usa/blog/ ) and there is no “Error 500 – Internal server error” now. I did something wrong that caused that to happen before. Still, the Post Archive links are not working. I don’t know why they worked for a second before, but I will keep trying.

    do you have some caching plugin active? usually those can cause issues like this, if you have some cache plugin deactivate it while you are testing out things, and activate only after everything is fixed. If fooled me a few times 😉

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘[Resolved] Post Archive links render "Not Found" after moving blogs’ is closed to new replies.