Support » Fixing WordPress » Post and Edit redirects to Home without saving

  • Hello everyone!

    The problem is this: whenever I try to post or save an entry in WP2.5.1 it sends the browser (FF2, FF3b, IE7) to the home page of my site without any error and without making the desired changes.

    I’ve tried disabling all plugins; manually disabling autosave; completely reinstalling everything right down to the database; but to no avail.

    I really don’t want to start posting via SQL!

    Any help is really greatly appreciated!

Viewing 10 replies - 1 through 10 (of 10 total)
  • obviously this wasn’t always like this, so what changed?

    don’t say ‘nothing’, that’s never true.

    Hey, i’ve had this exact same problem – It started without me doing anything to the site, with the old version of wordpress (2.3.x i think) so i thought i’d upgrade to try and fix the problem, but it’s not helped..

    The weird thing is though, when i try and make an edit it redirects me to the actual domain root, as in “www.everythingitunes.com” when the wordpress install is in a subfolder of the domain – “www.everythingitunes.com/os/windows”.

    I have two wordpress installs, one in /os/windows and one in /os/mac, and they both redirect back to the main page. I’ve tried deleting and recreating all my .htaccess files but nothing changed…

    People have also reported problems with getting blank pages when trying to comment. I’ve tried anything i can think of, such as using the default theme, and disabling all plugins etc.

    Sometimes, if i leave the edit page open, after exactly one minute, it seems, the homepage loads in one of the frames of the edit page..

    See screenshots… (in particular, look at after – part 4.

    [BEFORE] http://i27.tinypic.com/2hn6dsp.jpg

    [AFTER – Part 1] http://i25.tinypic.com/15d57nm.jpg
    [AFTER – Part 2] http://i28.tinypic.com/1534ahl.jpg
    [AFTER – Part 3] http://i29.tinypic.com/2cdhiir.jpg
    [AFTER – Part 4] http://i30.tinypic.com/2yn00eh.jpg

    Thanks in advance for any help..!

    I just made sure “Use Visual Editor when writing” was unchecked. Apparently that can be the cause – no luck though, it was already un-ticked.

    When creating a new post, it is possible to type the name of the post, but as soon as i press tab, or move the cursor into the main box to type the post’s text, the same thing happens as in the “after” screenshots above…

    EDIT: NO, It doesn’t work in IE either, seems to have just been coincidence that it worked for a while… At the same time, it started working with Firefox, too

    I’m using eUKhost hosting – what are you using, and what version of PHP etc do they have?

    Original Post

    OK geoffbrady – i think i might have a temporary fix. Try using IE instead of FireFox. It’s been playing up in Firefox, both v2 and the new v3 betas.

    For now it seems to be working in Internet Explorer though…

    Let me know how you get on..!

    You know, I’m using eUKhost as well…

    Edit 1: I’ll try this about mod_security in .htaccess and see if that works.

    Edit 2: That seems to have worked… if I get hacked I’ll blame them!

    @ivovic: It wasn’t always like this. Before upgrading to WP2.5.1 I was able to post perfectly well.

    Thanks a lot geoff, that’s sorted it perfectly!

    I don’t understand why it would just be the one host that this applies to..!

    For the record, http://www.eukhost.com are an excellent company, that have brilliant cust. support, and very cheap packages (£23/year) for a pretty good uptime and quality of service…

    I’m having the exact same issue. Unfortunately applying the mod_security fix did nothing for me.

    I use dreamhost.com as my host.

    I resolved my issue by upgrading WordPress to 2.7.1

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Post and Edit redirects to Home without saving’ is closed to new replies.