WordPress.org

Forums

Post 3.8.1 media upload troubles (21 posts)

  1. Zanimul
    Member
    Posted 1 year ago #

    I have several websites running WordPress 3.8.1, using three different hosting services. What occurs is on upload of seemingly any image - I've tested a smattering of sizes - the image appears to upload, gets to the "crunching" part then nothing further happens, no matter how long I wait. The next page with the thumbnail and "Edit" link never appear. Further, the resized versions are never created. Consequently, the image is pretty much unusable in any fashion the direct link to the image gives a 404 error.

    I've tried several "fixes" to no avail, gone plain vanilla, no plugins and the 20-14 theme, bumped the memory in the wp-config file all to no avail. The problem seemed to start with the 3.8.1 upgrade, however, at least one site is still at 3.8 and exhibits the same problem - I may have not noticed it in 3.8.

    The common denominator is the hosting service, the problem is only occurring on the sites that are hosted with 1and1, all the others are fine. Using the "TPC! Memory Usage" plugin, I've discovered that 1and1 is using MySQL v5.1.73 - whereas the others are using v5.5.36. PHP versions are the same, save for one of the hosting services which is at 5.3.13 vs 5.4 on the others - but the older php version does not exhibit the issue.

    Need help on this as the problem turned up just as we were bout to go live with the newest site.

    [Moderator Note: No bumping, thank you.]

  2. bas82
    Member
    Posted 1 year ago #

    I have exactly the same problem.

    I use a dedicated server with cPanel, and know my way around. I have the latest version of GD installed. Also on my vBulletin forum the GD function works perfect.

    But in WordPress it doesn't anymore. Also running 3.8.1. The image gets uploaded, can see it in my media, but resizing or using it doesn't work. I have 2 blogs with the same problem. Even tried chmod 777 and double checked permission.

    In short, the file gets uploaded without problems, but the editing/resizing doesnt work. The error message is not there. wp-admin/themes.php?page=custom-header&step=2 is the page where it happens for instance. Any suggestions are really appreciated.

  3. bas82
    Member
    Posted 1 year ago #

    After more searching I still have no solution. I have recompiled apache/php with gd (which already was enabled and working).

    Php -m gives also that the correct modules are installed:
    root@tank [~]# php -m
    [PHP Modules]
    bcmath
    calendar
    Core
    ctype
    curl
    date
    dom
    ereg
    filter
    ftp
    gd
    hash
    iconv
    imagick
    imap
    json
    libxml
    mysql
    openssl
    pcre
    Phar
    posix
    Reflection
    session
    SimpleXML
    sockets
    SPL
    SQLite
    sqlite3
    standard
    tokenizer
    XCache
    XCache Cacher
    xml
    xmlreader
    xmlwriter
    zlib

    [Zend Modules]
    XCache
    XCache Cacher

    Plugins of wordpress disabled. Will try to reupload or something?

  4. jochehuang
    Member
    Posted 1 year ago #

    i also cant find a way to may my pictures display full size in the latest versioin. its tiny and the alignment is the only button i see to change. no thumbnail medium large and full size:( help please

  5. esmi
    Forum Moderator
    Posted 1 year ago #

    If you require assistance then, as per the Forum Welcome, please post your own topic.

  6. bas82
    Member
    Posted 1 year ago #

    I still can't figure it out.

    /wp-content/ ownership and rights are set correctly, chmod 755 as in the documentation.

    The file gets uploaded and shows in the directory like 2014/02/filename.jpg but the creation of the thumbnail doesn't occur. No error message is seen after uploading. Also when choosing a custom header the same problem occurs.

    Apache error_log doesn't show an error. Php info shows GD enabled. On the same install there is a vbulletin installation that works perfectly with GD, so looks like wordpress is the problem. Also recompiled Apache with php, but that doesn't do the trick.

    How else can I troubleshoot this problem?

  7. Zanimul
    Member
    Posted 1 year ago #

    bas82, I'm trying to work this problem with 1and1 as well and the last message I got from them talked about moving to upper level hosting program that would allow more memory for WP. The current level my site is on is limited to I believe either 32 or 40 MB. Given the information below, I'm not sure that is warranted:

    Usage Sample: 16.87MB (7%)
    Peak Usage: 16.91MB (7%)
    All-Time: 22.02MB on 2/9/14 @ 7:32 pm (shutdown)
    Load Averages: 4.04 3.2 3.04
    WP Memory Limit: 128M
    PHP Memory Limit: 120M

  8. bas82
    Member
    Posted 1 year ago #

    Web Server Apache v2.2.26 (cgi-fcgi)
    PHP 5.4.25
    PHP Max Post Size 32.00 MB
    PHP Maximum Upload Size 36.00 MB
    PHP Memory Limit 364.00 MB
    MySQL Version 5.5.35-cll
    MySQL Packet Size 64.00 MB

    These are my settings, they should be more than enough according the wordpress documentation.

  9. bas82
    Member
    Posted 1 year ago #

    @Zanimul: Does your host also use cpanel? Do you know which version of ImageMagick they are using? It appears I use an outdated version:

    root@tank [~/download]# convert --version
    Version: ImageMagick 6.2.8 05/07/12 Q16 file:/usr/share/ImageMagick-6.2.8/doc/index.html
    Copyright: Copyright (C) 1999-2006 ImageMagick Studio LLC

    Maybe that is the problem?

    Also I have managed to get the following error into my error_log: libgomp: Thread creation failed: Resource temporarily unavailable wordpress

    Running apache with phphandler suphp. When I switch to phphandler dso it works. But I want to run suphp :(

  10. Zanimul
    Member
    Posted 1 year ago #

    @bas82: This particular one is being run on a biz account with 1and1, who are now claiming that the client should throw more money at them to increase the amount of memory available. Consequently, there's no CL access nor access to Apache/PHP config files.

    I've found that I can upload large files via the Nivo Slider upload interface and that goes off without a hitch. Which makes me very suspect of the post processing thumbnail creation that WP does when uploading images.

  11. bas82
    Member
    Posted 1 year ago #

    Well gladly I found the problem. The old version of ImageMagick seemed to be the culprit. I suggest your host to update it to the latest version. I can't guarantee it will work for you, but it did for me.

  12. suhakaralar
    Member
    Posted 1 year ago #

    Just install this plugin
    https://github.com/getsource/default-to-gd
    and back to the old happy days:)
    This little plugin changes the usage of Imagick Image Processing Library to GD Image Library as used to be. That's it.

  13. jackjewell
    Member
    Posted 1 year ago #

    Since "upgrading" to WordPress 3.8.1, I have been unable to upload ANY images! The buttons have changed since earlier version. On Gallery / Add Images, I choose a Gallery, hit Add Files, select image(s), hit Start Upload - makes sense to me. WordPress gives the message in upper right corner "Upload complete, 0 files uploaded." And nothing is there! Please help me, and PLEASE(!) do not make changes to formats without any explanation of how to work with the changes! My recent race photos cannot appear on my website, I emailed small files (the size used for website) to entities, and they're now all over the race website and various Facebooks. And my website merely has an embarrassing tiny thumbnail. Biting my tongue at the moment.
    Unhappy Jack
    http://www.jackjewellphoto.com/?page_id=76

  14. julienne
    Member
    Posted 1 year ago #

    Why use plugins just to have Images in posts?

    Would it not be better that the WP programers find the cause.

    I have a site even though its updated every time that still gives a headache on Image uploads.

    My way...DIY.

    <div align="center"><img src="http://www.flowersnpalms.com/fauna/hummingbirdhawkmoth.jpg" style="border: 6px white inset; alt="HummingbIrd Hawk Moth" width="220" height="147"/></div>

    Works everytime but should'nt be needed.

    J

  15. jeyon001
    Member
    Posted 1 year ago #

    i tried the "default-to-GD" plugin - but it didn't work for me

  16. energise
    Member
    Posted 8 months ago #

    I've been having the same problems with PHP 5.4.32 and WP 4.0

    Anyone come up with a proper fix yet?

  17. Daniel Payne
    Member
    Posted 6 months ago #

    I'm running WordPress 4.0 on 1and1 web hosting and just experienced this same media upload issue. The suggested plugin default-to-gd did not change anything for me.

    The plugin to resize all thumbnails also didn't fix this media upload bug.

    I'm still stuck, open to suggestions.

  18. Marko Heijnen
    Member
    Posted 6 months ago #

    Hey All,

    At 1&1 the plugin "default-to-gd" will not work since we still use GD. Unsure yet when we will install Imagick. Our limits do depend on the tariff you chosen.

    Marko

  19. jaytor
    Member
    Posted 6 months ago #

    I am having similar problems, I can't seem to upload pictures via add media. It keeps giving me HTTP Error, I have tried to deactivate all plugins the same results, I have also tried the default to gd plugin and it didn't work. I have no idea what is going on because it worked earlier for me when I uploaded several images but it stopped all of a sudden with no changes in plugins.

    Also using WordPress 4.0. I am open to any suggestions as well.

  20. Daniel Payne
    Member
    Posted 6 months ago #

    My fix to this media uploading at web host 1and1 was to add a file called php.ini in the /wp-admin folder:

    max_input_time = 60
    max_execution_time = 120
    upload_max_filesize = 64M
    post_max_size = 64m
    memory_limit = 256M
  21. jaytor
    Member
    Posted 6 months ago #

    I am not sure if Daniel Payne code help or not, but I inserted it and I tried to upload the picture I was having trouble with and it still didn't work. However, if I uploaded other pictures other than the one that had trouble it worked.

    Thanks for the help!

Topic Closed

This topic has been closed to new replies.

About this Topic