Support » Plugin: footnotes » Possible to hide it from start page ?

  • Resolved dragon013

    (@dragon013)


    Hello,

    maybe I missed an option, but is there a way to hide the footnote displayed in a widget from start page ?

    I do have a start page in my blog showing all new blogposts (just the usual way of a blog). In the right sidebar, footnotes are displayed when a post is shown fully. That’s ok. But it also is shown on start page with all footnotes of the posts listed on the first page. Is there a way to hide this ?

    Thanks for any help!

    Dragon013

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Contributor pewgeuges

    (@pewgeuges)

    @dragon013

    Sorry please, I missed out on your request. That shouldn’t happen. We needed to fix lots of bugs, but now we’re nearly done and I’m going through the Forum. Apologies again! Also for the strange behavior on your start page, that seems to be related to a mistake I made when releasing bugfix 2.0.5 and 2.0.6: https://wordpress.org/support/topic/change-the-position-5/page/2/#post-13630114

    Is the problem gone with current stable 2.1.0?

    An upcoming bugfix 2.1.1 is currently available in preview as 2.1.1d7 at https://downloads.wordpress.org/plugin/footnotes.zip This contains the most we were able to fix up to now.

    I beg your pardon for this response coming so late.

    Best regards,
    @pewgeuges

    • This reply was modified 7 months ago by pewgeuges.
    • This reply was modified 7 months ago by pewgeuges.
    Thread Starter dragon013

    (@dragon013)

    Hello,

    I just checked 2.1.0 and preview of 2.1.1, but sadly the widget is still shown on start page and not only in fullpage view of article.

    Do you need any further information about it ?

    Best,
    Dragon013

    Plugin Contributor pewgeuges

    (@pewgeuges)

    @dragon013

    Thanks for testing and for reporting the issue. An option shall be added to toggle visibility of the reference container on start page, with respect to users wishing footnotes there too, which prevents the rule from being added now to the plugin’s public style sheet.

    A quick solution is to add this rule to the Custom CSS of your theme:

    
    .home .footnote_container_wrapper { display: none; }
    

    But the class name of the container, that I added for v2.0.3 to prevent a page break just after the label, is silly (it was even footnote_container_overall_wrapper) and is changing to footnotes_reference_container. Hopefully the previous ones are not yet in Custom CSS of websites.

    Thank you for helping improve the Footnotes plugin!

    Best regards,
    @pewgeuges

    Thread Starter dragon013

    (@dragon013)

    The workaround with custom css works. Thanks for that!

    Plugin Contributor pewgeuges

    (@pewgeuges)

    @dragon013

    Glad it helps! Thanks for the info. However, in our next release, as mentioned the class name will change to a more convenient one. Please don’t bother updating custom CSS, just go to the plugin’s dashboard > Settings > Reference container > Display on start page too -> No. This will embed the following rule in the page head:

    
    .home .footnotes_reference_container { display: none; }
    

    Almost the same but rid of the “wrapper” bit.

    Sorry for this inconsistency, and thanks again: This is your feature!

    Thread Starter dragon013

    (@dragon013)

    Thanks! I will keep an eye on it.

    Thread Starter dragon013

    (@dragon013)

    Just installed the new version and tested the new feature. It works like a charme! Thanks for your work!

    Plugin Contributor pewgeuges

    (@pewgeuges)

    Thank you for your feedback!!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Possible to hide it from start page ?’ is closed to new replies.