Support » Plugin: Regenerate Thumbnails » Possible to continue from where it left off?

  • Installed this plugin on a site that has over 5k images. Client changed theme and now have to regenerate all thumbnails.
    However the plugin stops/hangs up at 45% and when i try to do it again, it starts from the beginning.
    Is there a way to get this to continue from where it left off and not re-do the entire stuff again?

Viewing 4 replies - 1 through 4 (of 4 total)
  • You can regenerate specific images from the media library when in the list view, if that helps. There’s also the “Skip regenerating existing correctly sized thumbnails (faster)” checkbox, have you tried enabling that and regenerating again?

    Hi,

    1. Since it’s an complete theme change, manually doing it for specific images takes a lot of time. For one or two images, it is ideal but for 5k+ images, it’s a nightmare 🙁

    2. Yes. The checkbox is/was ticked during each instance of running the plugin. And i made it a point to note down the names of the first 20-30 images that showed up in the list and it was the same set.

    Plugin Author Donncha Ó Caoimh

    (@donncha)

    Did any error show in the php error log when the plugin stopped?

    Have you tried using wp-cli to update? For that number of images this could work a lot better and faster. You can find more info here:
    https://wp-cli.org/
    https://developer.wordpress.org/cli/commands/media/regenerate/

    Any way I can run WP-CLI media regenerate command with Plesk server?

    tried:

    plesk ext wp-toolkit –wp-cli -instance-id 2 -path /var/www/vhosts/xxx/httpdocs — media regenerate –yes

    won’t work for me…

    • This reply was modified 2 weeks, 1 day ago by pjaspen.
Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.