Support » Plugin: All in One SEO Pack » Possible problem with 3.6 beta 4

  • I’m testing WordPress 3.6 beta 4 and when I activate All In One SEO I get this error mesage:

    Strict Standards: Declaration of All_in_One_SEO_Pack::get_current_options() should be compatible with All_in_One_SEO_Pack_Module::get_current_options($opts = Array, $location = NULL, $defaults = NULL, $post = NULL) in C:\xampp\htdocs\wp36_Expressions\wp-content\plugins\all-in-one-seo-pack\aioseop_class.php on line 12

    Is this something that should be looked at?

    http://wordpress.org/extend/plugins/all-in-one-seo-pack/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Contributor Peter Baylies

    (@pbaylies)

    kevin,

    Are you running PHP 5.4? See if you can turn off error reporting of strict standards, i.e., do something like this in your php.ini:

    error_reporting = E_ALL & ~E_NOTICE & ~E_STRICT

    In the meantime, I’ll look at that issue, and start developing with it turned on, I’m currently testing with PHP 5.3.15 over here, I guess I should try 5.4 as well…

    Hi Peter

    I’m using 5.4.4 and have error handling set to E_ALL.

    I like to see all errors when I’m coding, because I usually make a few :).

    Plugin Contributor Peter Baylies

    (@pbaylies)

    kevin,

    This will be fixed in the next version; thank you for the report!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Possible problem with 3.6 beta 4’ is closed to new replies.