Support » Plugin: WordPress Popular Posts » Possible PHP 8 issue

  • Resolved outdoorsdev1

    (@outdoorsdev1)


    Just wanted to report this. Have been testing PHP 8 and since gone back to 7.4 as i’ve had a few issues with various things.

    I caught this in my debug.log though I didn’t see anything on the front end, I was working on something else entirely.

    [02-Feb-2021 13:55:17 UTC] PHP Deprecated:  Required parameter $rating follows optional parameter $data in .../wp-content/plugins/wordpress-popular-posts/src/Output.php on line 789
    [02-Feb-2021 13:55:17 UTC] PHP Deprecated:  Required parameter $themer follows optional parameter $public_options in .../wp-content/plugins/wordpress-popular-posts/src/Output.php on line 88
    [02-Feb-2021 13:55:17 UTC] PHP Deprecated:  Required parameter $rating follows optional parameter $data in .../wp-content/plugins/wordpress-popular-posts/src/Output.php on line 789
    [02-Feb-2021 13:55:17 UTC] PHP Deprecated:  Required parameter $translate follows optional parameter $public_options in .../wp-content/plugins/wordpress-popular-posts/src/Output.php on line 88
    [02-Feb-2021 13:55:17 UTC] PHP Deprecated:  Required parameter $themer follows optional parameter $public_options in .../wp-content/plugins/wordpress-popular-posts/src/Output.php on line 88
    [02-Feb-2021 13:55:17 UTC] PHP Deprecated:  Required parameter $rating follows optional parameter $data in .../wp-content/plugins/wordpress-popular-posts/src/Output.php on line 789
    
Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Héctor Cabrera

    (@hcabrera)

    Hi @outdoorsdev1,

    Thanks for the heads up! Someone else had reported this before as well but I can’t remember where.

    I looked into it and I think I have a potential fix ready, just haven’t had the chance to set up a Docker container to fully test WPP under PHP 8 yet.

    I’ll leave a comment here (and possibly push a new update too) once I’m done testing.

    Plugin Author Héctor Cabrera

    (@hcabrera)

    Hey there!

    Just so you and anybody else reading this know: Improves compatibility with PHP 8.

    There are still a few things I want to work on so this fix won’t make it to the WP repository just yet but thought you may want to know.

    Sean

    (@sean-h)

    If I may chime in here. I’m running WPP on 2 sites using Siteground’s Ultra Fast php 8.0.2, so far so good.

    Here is one such live site, https://www.thetastychilli.com, but I’m still monitoring, so first sign of trouble anywhere I may have to revert to 7.4

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.