Support » Plugins and Hacks » Possible jQuery error? Not sure..

Possible jQuery error? Not sure..

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Maeve Lander


    Have taken a quick look and yeah this is definitely a conflict with JS that is hardcoded into your theme. Right click > view source > scroll to the bottom and you will see a whole bunch of scripts that are there in the theme files. See FAQs 5th point down for further help with resolving this.

    Second issue… for the Pro player the shortcode is specific to each playlist…. go to Manage Playlists and you’ll see the shortcode for each playlist you create.

    Hope this helps you out 🙂

    I read those articles, and tried what he said, but I’m not sure where to go from here. I asked the theme author, and tried what he said to no luck either.

    I think what’s causing the conflict is that the theme uses a jQuery player for blog audio post formats–so when it calls for “jplayer” it goes to the one built into the theme.
    I don’t necessarily want to get rid of the theme one, because I would like to use it in blog posts. But, is there a way to distinguish yours and force it to get the styling and js commands from your plugin before it gets it from the theme?

    I have no idea…I’m not a coder.

    Update: I have determined it is the style.css, although now the play button is off in right field for whatever reason…

    http://www.thesearchforaesthetic.com/artists/josh-mcknew/music/ see now

    And if I remove the jplayer style from the stylesheet, the one in the theme breaks. Is there a way to have both running? Like tell it to use one jplayer style for pages and one for blog posts or something?

    Plugin Author Maeve Lander


    Sorry if you have another audio player running on your site it is very likely to cause conflicts. Unfortunately no I can’t really suggest any easy fix for this.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Possible jQuery error? Not sure..’ is closed to new replies.