Support » Plugin: Jetpack Boost » possible incompatibility with woocommerce

  • Resolved caperadd

    (@caperadd)


    I’ve since deactivated Boost from our production site, and thus can’t provide many more details. But we were having issues with Boost and Woocommerce, getting an “Unable to fix malformed JSON” error in checkout.min.js in several of the latest woocommerce versions.

    Practically, this was creating an error when proceeding to checkout, that said “SyntaxError: Unexpected end of JSON input”

    I suspect boost’s JS deferring was breaking something here but couldn’t look much further and don’t have a wordpress account for our dev site.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author pyronaur

    (@pyronaur)

    Hi @caperadd,
    Does disabling Defer JS fix the issue?

    Thread Starter caperadd

    (@caperadd)

    It does. And my original post is mistaken, the error occurs on place order in woocommerce, not proceed to checkout.

    Plugin Author pyronaur

    (@pyronaur)

    Thanks for the report – I found the issue. I’ll ship a fix for it in the coming hours – keep an eye out for the update 🙂

    Thread Starter caperadd

    (@caperadd)

    Confirmed that it’s working! Thank you!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘possible incompatibility with woocommerce’ is closed to new replies.