WordPress.org

Support

Support » Plugins and Hacks » BulletProof Security » [Resolved] Possible iFrames issue causing incompatability with Jetpack

[Resolved] Possible iFrames issue causing incompatability with Jetpack

  • The Jetpack author suggested I come to this forum, so I hope you can help.

    URL: shebloggedbynight.com

    Theme: Brunelleschi

    Previous thread on the Jetpack forums: http://wordpress.org/support/topic/etpack-comments-dont-work-after-update-to-wp-35?replies=9

    I have used Jetpack, including the comments options, along with Bulletproof for several months without problem. But when I upgraded to WP 3.5, my Jetpack comments no longer worked. What would happen is that I would try to reply, and when I would submit, the box the reply should have been in would show another copy of my blog.

    Jetpack comments DO work if I disable Bulletproof and get a new .htaccess file. But once I re-enable Bulletproof and generate the secure .htaccess file, Jetpack comments stop working again.

    Jetpack author Jeremy Herve suggested it was an iFrames issue, as you can tell on the thread I linked to.

    I’d really like to use both Bulletproof and the Jetpack comments, but right now I have to disable Jetpack comments as a workaround. What can you tell me about this issue, and is there anything that can be done?

    http://wordpress.org/extend/plugins/bulletproof-security/

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author AITpro

    @aitpro

    Just for good measure first – Have you installed BPS .47.7? There is an issue with WP 3.5 and previous versions of BPS that is fixed in .47.7.

    This person asked the same question in this thread and i tested Jetpack commenting and did not find a problem on a standard WordPress single site installation, but did discover some strange issues on a GWIOD WordPress installation. Of course something could have changed again. In the coding world things change constantly so nothing is ever really done or finished and can only be considered as done or finished for the moment. I will test the latest version of Jetpack and see what happens.

    http://wordpress.org/support/topic/jetpack-comments-404?replies=8

    Plugin Author AITpro

    @aitpro

    Ok i have found the problem code. I tried whitelisting wordpress.com (shown as an example below) and that did not work. This code does not really stop Referrer Spambots anymore (spammers have already figured out how to beat this code) so it is scheduled for removal. Delete this code in your Root .htaccess file.

    # FORBID EMPTY REFFERER SPAMBOTS
    RewriteCond %{REQUEST_METHOD} POST
    RewriteCond %{REQUEST_URI} (wp-comments-post\.php)
    RewriteCond %{HTTP_REFERER} !^.*ait-pro.com.* [OR]
    RewriteCond %{HTTP_REFERER} !^.*wordpress.com.* [OR]
    RewriteCond %{HTTP_USER_AGENT} ^$
    RewriteRule .* - [F]
    Plugin Author AITpro

    @aitpro

    Please resolve the thread after confirming removing the code works. Thanks.

    Deleting that part of code worked, thanks.

    big thanks!

    Thanks for the update @aitpro.

    I don’t know if others had to do this but I had to re-deploy the Bulletproof mode to get the changes to kick in.

    I had to do that as well. Thanks for bringing it up mrwweb, I never thought of mentioning it.

    I’ve been having major issues with comments on my blog as well. Where exactly do I go to remove that bit of coding?

    Thanks!

    Plugin Author AITpro

    @aitpro

    If you have the latest version of BPS installed then click the AutoMagic buttons and activate root folder BulletProof Mode and wp-admin BulletProof Mode. That problematic FORBID EMPTY REFFERER SPAMBOTS code is no longer created by AutoMagic.

    What’s does BPS do? The theme on my website is Twenty-Eleven and the domain is http://www.misschaostown.com. I just disabled Jetpack Comments last night but still waitiing for feedback as to whether comments will work now or not.

    Plugin Author AITpro

    @aitpro

    I don’t understand the question. Please be more specific.

    Plugin Author AITpro

    @aitpro

    I checked your website and you do not have the BPS plugin installed. Were you asking a general question about comment issues/problems on your website?

    Sorry for not being more clear. Yes, it was a general question as to why readers could not comment on my blog. After reading through threads in this forum, I learned that themes have their own default comment sections programmed into them and so I deactivated JetPack’s comments and now it appears that the comment function is working.

    I’ve seen people mention ‘BPS’ and asked a general question about what that plugin does but I suppose I could just as well google it. Thanks.

    Plugin Author AITpro

    @aitpro

    Oh ok I was not exactly sure what the question was.

    A description of what BPS is and does can be found in both of these links
    http://wordpress.org/plugins/bulletproof-security/
    http://wordpress.org/plugins/bulletproof-security/faq/

    Thank you! 🙂

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Resolved] Possible iFrames issue causing incompatability with Jetpack’ is closed to new replies.
Skip to toolbar