WordPress.org

Forums

FAQ Manager
[resolved] possible conflict with WP Multilingual (4 posts)

  1. teresape
    Member
    Posted 2 years ago #

    Hi!
    I'm using safari 6.0, WP 3.5.1. and FAQ manager 1.331
    I can't put a link of my site, because I'm working local, before update the live site.

    Since I've upgraded to FAQ manager 1.331, there is a problem with duplicate content only with the pages that have a FAQ code inside. I've noticed, after many tries (activating and deactivating plugins, even changing the theme), that is when WP multilingual is activated, and I need both plugins working together!

    The content duplicated, is just the belong to "the_content()", I mean, the content of the page. This is not happening in the pages that not have FAQ codes.

    The only solution by the moment is enter the faqs by manual code in the content, but this is a great plugin, and my client is used to manage already and very happy with it.

    Any idea would be appreciated!!!
    thank you!

    http://wordpress.org/extend/plugins/wordpress-faq-manager/

  2. teresape
    Member
    Posted 2 years ago #

    I'm sorry, there was a post wiht this problem:
    http://wordpress.org/support/topic/faq-showing-up-twice?replies=8#post-3852896
    FAQ showing up twice

    And a solution:

    Takao Asayama 朝山貴生
    Member
    Posted 2 weeks ago #
    I found out wp_reset_query() was causing it in all shortcode functions. Just deleted it and works perfectly. FYI

    That works! :-)
    I just commented the function 3 times, and it's working!

    But I don't like to edit the code in plugins, because the upgrade will rewrite the php and the temporal "solution". I have to advice my client not to upgrade in the future, and is a little bit awkward.

    Maybe the developer have any idea about this bug?
    thank you for your attention!!!

  3. Andrew Norcross
    Member
    Plugin Author

    Posted 2 years ago #

    it's not normal for wp_query to be causing issues, esp since it's been there since I first released it. I will go through and find the root issue.

  4. teresape
    Member
    Posted 2 years ago #

    thanks for check it out!

    Finally I updated all the plugins on live version, with the "patch" in your plugin...
    http://www.greyelephant.es/faq/
    http://www.greyelephant.es/cumpleanos/

    I have tried again, uncomment the code (wp_reset_query()) of faq-manager.php and it's still duplicating the content...
    Just remember to you, that in my case, the problem happens only when WPML (WP multilingual) is activated and working together...

    thanks again!
    ciao!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • FAQ Manager
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.