Support » Plugin: NGG Smart Image Search » Possible Conflict with WordPress Page Password Feature

  • Resolved James

    (@jmdesignsolutions)


    Hi,

    I’m trying to integrate this plugin with a gallery on a password protected page. Everything loads fine when the content is not password protected but whenever I enable the password feature for the page and then search the page refreshes and I have to log back in again and no results are displayed.

    Is this is a possible issue/conflict?

    Any help/advice would be appreciated.

    Thanks,

    James

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author wpo-HR

    (@wpo-hr)

    Hi James,

    the search result page will get its search parameters by the calling instance as a call ($POST) parameter. If your result page is password protected I assume that this parameter gets lost as you have to enter the password first. By continueing from the password form to the search result page the previous parameter will probably not be passed on. Therefore no result can be displayed.
    This is not an issue or conflict, it is just not designed to work this way.

    If you want a private / protected result page I could image two approaches:
    (1) define a password protected page, where you only place a searchbox. Then use the searchbox target parameter to redirect to a different search result page, which is not password protected. Disadvantage: searchtext entry and search result list will display on two different pages.
    (2) use a standard guest account on your wordpress site and make search a private function / page. You can even use the plugin UAM user access manager to define an own user group for this search function.

    Best regards
    Harald

    James

    (@jmdesignsolutions)

    Hi Harald,

    Thanks for the reply and for the information.

    I’ve gone with the 2nd option you mentioned and have got it all working correctly now.

    Thanks for your help!

    James

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.