Support » Plugin: Elementor Page Builder » Possible compatibility issue latest Gutenberg Update

  • Resolved VP

    (@studio500)


    Just to let you know, I just updated my Gutenberg plugin to the latest release and immediately received a fatal error that may be due to a conflict with Elementor.

    Fatal error: Uncaught Error: Call to undefined function Elementor\gutenberg_can_edit_post_type() in /home/bisfhous/public_html/wp-content/plugins/elementor/includes/compatibility.php:54 Stack trace: #0 /home/bisfhous/public_html/wp-includes/class-wp-hook.php(286): Elementor\Compatibility::add_new_button_to_gutenberg(”) #1 /home/bisfhous/public_html/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(”, Array) #2 /home/bisfhous/public_html/wp-includes/plugin.php(465): WP_Hook->do_action(Array) #3 /home/bisfhous/public_html/wp-admin/admin-header.php(120): do_action(‘admin_print_scr…’) #4 /home/bisfhous/public_html/wp-admin/edit.php(353): require_once(‘/home/bisfhous/…’) #5 {main} thrown in /home/bisfhous/public_html/wp-content/plugins/elementor/includes/compatibility.php on line 54

Viewing 4 replies - 1 through 4 (of 4 total)
  • VP

    (@studio500)

    I reached out to the Gutenberg editors on Github and have been told that this is an elementor issue.

    The reply received is below:

    “yes gutenberg_can_edit_post_type is a plugin function and not something that is available in Core. I suggest and it was deprecated two releases ago (in the plugin). I suggest reaching out to Elementor.

    Thanks.”

    raven747

    (@raven747)

    Yup also experienced this issue. Elementor needs an update to address this, or the two simply cannot exist at the same time.

    cavalierlife

    (@cavalierlife)

    A fix will be released soon for this.

    raven747

    (@raven747)

    thanks for the update!

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.