Support » Requests and Feedback » Possible bug report Category pages

Possible bug report Category pages

  • I have my “real” blog here (v. 1.5) which, for ease of viewing the difference you should themeswitch to Kickass- Convergence.

    I have my “test” blog here (v.

    Same theme, same content in files, yet when you click a category
    page, the text in the post does not “paragraph” in the new one like it does in the old one– instead it has br tags inserted singly when
    linebreaks occur, so nothing is “paragraphed”- and it ONLY does this on category pages. I looked thru admin for options, I looked at the php/xhtml, I looked at the css, I looked at EVERYTHING and there’s nothing there to account for this, and nothing that succeeds in changing it.

    To make sure I wasn’t going nuts I asked vkaryl to check her category pages. It does this with most themes, it always uses a single br tag anyplace I hit the enter key twice to signify the end of a paragraph, and it only does it on category pages on installations. It also adds a LOT of spaces after the initial p tag.

    I have a feeling it’s in the core somewhere, and I’m not going there without a LOT of help from one of you php wizards. It would be nice if it’s just a simple fix we can add to a file (instead of another upgrade . . . grumble, grumble)

Viewing 15 replies - 1 through 15 (of 24 total)
  • Update- it does the br thing with Kubrick live (only on test blog) does NOT do it with classic live. It’s currently set back to Kickass- Convergence.

    Oh, I should mention, there’s only one category on the test blog, it’s called “One” and is in the horizontal navbar under the header.

    It could very well be a plugin or a theme disabling wpautop, which inserts the paragraphs. Check to see if there’s any remove_filters in plugins or themes.

    Nope – that’s not it here. The only one of my plugins which has anything about “remove” anything is Coldforged’s Enhanced Views, it has a “remove_parameter” line with a couple of $p variables in it, but deactivating it didn’t fix the lack of paragraphing….

    And it really isn’t a problem in WP Classic either, which means it probably COULDN’T be a plugin….

    I only have one plugin active, and it’s the witty thing that adds random quotes. I looked. It doesn’t remove anything.

    As to it being a theme, why would multiple themes, including the kubrick theme installed on this JUST DONE INSTALL and with absolutely no edits done to it whatsoever, cause this problem in and not in 1.5? Your logic doesn’t hold up.

    Besides, the one I’m checking for plugin problems etc. has ONLY the WPClassic theme and one of my own I just developed. Classic works fine, my own does not – admittedly, mine is not based on the files in the Classic themeset, rather on the “default” themeset I believe.

    I don’t know that it’s a core-file problem though, simply BECAUSE there’s two different themesets here, with the situation showing only on the themeset developed from the default theme files.

    So I’m thinking this is just one more “little difficulty” with the default theme. It’s maybe in one of the files…. I haven’t had a chance to look yet – just got rebooted and back online again, thunderstorms and lightning this afternoon.

    Okay, it about has to be in one of the “archive” files – because it doesn’t happen in wp classic, which doesn’t have either archive.php OR archives.php.

    Guess I’ll go dig around some though since I’m not real swift with php files (other than includes), I don’t know that I’d know it when I found it!

    Edit: well, no, actually it doesn’t need to be in there. Maybe it might more likely be in wherever the_content or the_excerpt is contained and called from…. So that being the case, I amend my above statement about it NOT being in the core files.

    I don’t have my archives set up “weekly” or “monthly”, I’d be curious to hear if the same issue is happening on those pages using the original Kubrick theme unedited and on, with or without any plug-ins.

    And for the life of me I cannot see ANYTHING in that archive.php file that would cause this. There’s very little xhtml other than the occasional h2, h3 or p– it’s mostly php calls to the core files, and the calls appear to be codex-perfect, at least the ones I checked, like the call to the_exerpt.

    Yeah, I’ve been looking at a lot of the core files…. for one thing, it seemed as if functions-formatting.php might be a likely place to start, but the thing is, I just don’t know what I’m looking for really…. especially hard to find if it’s something “missing” to begin with!

    I have monthly archives – and any post needing paragraphing doesn’t have it…. just like the rest.

    “li’l whine” as I get ready to head off to bed….

    I just don’t know what I’m supposed to be looking for here. Of course, if it’s something that’s really missing, instead of just “misplaced” or something I’M doing wrong, I guess that’s not a surprise…. it seems almost impossible that only two of us actually have this problem though, y’know?

    None of you php-guru types have ANY clue? Kafkaesquí? No help showing? *sigh*

    Okay – I fixed it…. sort of….

    I renamed archive.php to 1archive.php and archives.php to 1archives.php.

    Voilá! Paragraphing properly. Any takers on why?

    [[In other words, this works, but I have no idea why or what the problem really was….]]


    That’s because it’s using your index.php to “build” the archive pages now.

    I ran a second test. I renamed archive.php to category.php. No paragraphing. Then I deleted archives.php off the server. No paragraphing. So I simply deleted category.php (formerly archive.php) off the server. Now I’ve got paragraphing. To further isolate where the problem is, I re-uploaded archives.php. I still have paragraphing. So the problem appears to be in the archive.php file. Now I’ve torn that damned file apart backwards and forwards and can’t figure it out. I zipped up the archive.php file and stuck it here:


    Could someone figure out what is in this code (or in the core) that is causing this? The only difference I can see in the loop is that index.php calls the whole post and not the exerpt.

    I opened archive.php and changed “the_excerpt” to “the_content”. Paragraphs are fine. So it’s apparently something in the function calls which is different.

    Here’s what I think: because you normally only see a short excerpt when you open an archive page, “the_excerpt” doesn’t need to use any form of paragraphing. However, unless for some unknown reason you want your category listing of posts to show only excerpts as well, it IS a problem if the category listing of posts uses “the_excerpt” instead of “the_comment” – and this is apparently what’s happening: the category page by default uses the same function as the archive page.

    So whatever part of whatever core file calls that for categories needs to be changed to “the_comment”. I haven’t had time yet today to go digging again, but I’ll see what I can find eventually. And of course, simply changing the call in archive.php works fine too – as a stopgap measure.

    My apologies, everyone! I was obviously in “blond and senior space-cadet” mode earlier…. that should read “the_content” NOT “the_comment”.

    I AM sorry – that will teach me to go off to barbeque lunch for a few hours!

    No problem, vkaryl!

    Anyway, it appears this paragraphing problem exists in (dunno about versions between 1.5 and the most recent) and only when the_exerpt is called. Could someone who has more php knowledge than I do PLEASE come up with a workaround? It used to work, now it’s broken.

    I also tried to post this on the bug board as a minor low priority bug fix, since it’s now known this is something that needs to be fixed in a core file and this is what I got:
    “Permission Denied

    This action requires TICKET_CREATE permission. “

    That coupled with the silence here from almost everyone who does WP dev makes me wonder what the h-e-doublehockeysticks is going on. I know this isn’t a security concern, or a major problem, but sheesh, it’s gotta be a really easy fix for someone who knows what they’re doing.

    Yeah, bit worrying the silence…. for now, I just overwrote all the archive.php pages in my blog themes with the “corrected version” – but that’s pretty well just like a cosmetic cover up for an ugly zit, y’know?

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘Possible bug report Category pages’ is closed to new replies.